Bug 208016 - Large Images cannot be printed
Large Images cannot be printed
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-25 16:54 EDT by antonio montagnani
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 12:24:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test of homework printing (1.41 MB, application/pdf)
2006-10-01 08:13 EDT, antonio montagnani
no flags Details
Cups error_log (603.48 KB, application/octet-stream)
2006-10-01 08:51 EDT, antonio montagnani
no flags Details

  None (edit)
Description antonio montagnani 2006-09-25 16:54:03 EDT
Description of problem:
Large images (>6Mb) cannot be printed

Version-Release number of selected component (if applicable):


How reproducible:
If i load a large image in the Gimp, I cannot print it at full page, if I reduce
it I can print. Same image loaded in any other application is printed fine.
I am using gdi driver on a laser printer from samsung (ML1610)

Steps to Reproduce:
1.load images
2.print it
3.nothing happens, green light is flashing
  
Actual results:
nothing

Expected results:
a print 

Additional info:
Comment 1 Tim Waugh 2006-09-26 04:56:58 EDT
Does /var/log/cups/error_log show anything interesting about it?
Comment 2 antonio montagnani 2006-10-01 06:00:28 EDT
I am trying to print also a PDF file and I get same problems: from error_log I
find. Also same probelms with a Openoffice document (also small).Everything
worked, and CUPS test page is o.k.

- Operation not supported
I [01/Oct/2006:11:42:22 +0200] Adding start banner page "none" to job 242.
I [01/Oct/2006:11:42:22 +0200] Adding end banner page "none" to job 242.
I [01/Oct/2006:11:42:22 +0200] Job 242 queued on "Samsung" by "root".
I [01/Oct/2006:11:42:22 +0200] Started filter /usr/lib/cups/filter/pstops (PID
2832) for job 242.
I [01/Oct/2006:11:42:22 +0200] Started filter /usr/lib/cups/filter/foomatic-rip
(PID 2833) for job 242.
I [01/Oct/2006:11:42:22 +0200] Started backend /usr/lib/cups/backend/usb (PID
2834) for job 242.
Comment 3 antonio montagnani 2006-10-01 06:18:32 EDT
Acrobat works if file is small: I successfully printed a 700 kb file, no way to
print a 11MB file.Very embarassing situation, take in account that most
documentation is PDF
Comment 4 antonio montagnani 2006-10-01 08:00:10 EDT
Same problem with Openoffice writer.
Small documents are o.k. but no way of printing large documents
My printer is a Samsung ML -1610 laser with gdi driver
Comment 5 Tim Waugh 2006-10-01 08:08:47 EDT
The error_log snippet provided in comment #2 doesn't show any errors at all, or
even warnings.  Are there none shown in error_log when the problem happens?

Please provide an example document or image that does not print.  Thanks.
Comment 6 antonio montagnani 2006-10-01 08:13:27 EDT
Created attachment 137496 [details]
Test of homework printing
Comment 7 antonio montagnani 2006-10-01 08:18:53 EDT
Additional infos from cups error log: hope that it can help

E [01/Oct/2006:13:47:29 +0200] [Job 271] Unable to write print data: No such device
E [01/Oct/2006:13:47:31 +0200] PID 7244 (/usr/lib/cups/filter/foomatic-rip)
stopped with status 9!
I [01/Oct/2006:13:47:31 +0200] Hint: Try setting the LogLevel to "debug" to find
out more.
I [01/Oct/2006:13:47:55 +0200] Adding start banner page "none" to job 272.
I [01/Oct/2006:13:47:55 +0200] Adding end banner page "none" to job 272.
I [01/Oct/2006:13:47:55 +0200] Job 272 queued on "Samsung" by "antonio".
I [01/Oct/2006:13:47:55 +0200] Started filter /usr/lib/cups/filter/pstops (PID
7321) for job 272.
I [01/Oct/2006:13:47:55 +0200] Started filter /usr/lib/cups/filter/foomatic-rip
(PID 7322) for job 272.
I [01/Oct/2006:13:47:55 +0200] Started backend /usr/lib/cups/backend/usb (PID
7323) for job 272.
I [01/Oct/2006:14:09:30 +0200] Adding start banner page "none" to job 273.
I [01/Oct/2006:14:09:30 +0200] Adding end banner page "none" to job 273.
I [01/Oct/2006:14:09:30 +0200] Job 273 queued on "Samsung" by "antonio".
I [01/Oct/2006:14:09:30 +0200] Started filter /usr/lib/cups/filter/pstops (PID
8323) for job 273.
I [01/Oct/2006:14:09:30 +0200] Started filter /usr/lib/cups/filter/foomatic-rip
(PID 8324) for job 273.
I [01/Oct/2006:14:09:30 +0200] Started backend /usr/lib/cups/backend/usb (PID
8325) for job 273.
E [01/Oct/2006:14:15:08 +0200] [Job 273] Unable to write print data: No such device
E [01/Oct/2006:14:15:12 +0200] PID 8324 (/usr/lib/cups/filter/foomatic-rip)
stopped with status 9!
I [01/Oct/2006:14:15:12 +0200] Hint: Try setting the LogLevel to "debug" to find
out more.
I [01/Oct/2006:14:15:27 +0200] Started "/usr/lib/cups/cgi-bin/admin.cgi" (pid=8601)
I [01/Oct/2006:14:15:27 +0200] Started "/usr/lib/cups/daemon/cups-deviced"
(pid=8602)
Comment 8 Tim Waugh 2006-10-01 08:31:44 EDT
Aha, now we're getting somewhere.  Can you please now edit /etc/cups/cupsd.conf
so that the LogLevel line reads:

LogLevel debug2

Then restart cups with '/sbin/service cups restart'.  Now you should get more
debug information shown in error_log, which would be very interesting to see.
Comment 9 antonio montagnani 2006-10-01 08:51:16 EDT
Created attachment 137497 [details]
Cups error_log

Done. restarted cups and tried to print a document....
Comment 10 Tim Waugh 2006-12-12 09:43:42 EST
So, job 274 printed successfully by the look of it.  Can you get a log from an
unsucessful print?
Comment 11 Bug Zapper 2008-04-03 23:50:39 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 12 Bug Zapper 2008-05-06 12:24:16 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.