Bug 2080198 - etcd leader changes produce test churn during early stage of test
Summary: etcd leader changes produce test churn during early stage of test
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Etcd
Version: 4.10
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.10.z
Assignee: Dean West
QA Contact: ge liu
URL:
Whiteboard:
Depends On: 2080197
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-04-29 08:41 UTC by Michal Fojtik
Modified: 2022-05-31 12:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 2080197
Environment:
Last Closed: 2022-05-31 12:40:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 27076 0 None open [release-4.10] Bug 2080198: skip tests for etcd leaders when etcd revisions change a lot 2022-05-18 01:01:21 UTC
Red Hat Product Errata RHBA-2022:4754 0 None None None 2022-05-31 12:40:30 UTC

Description Michal Fojtik 2022-04-29 08:41:52 UTC
+++ This bug was initially created as a clone of Bug #2080197 +++

Description of problem:

etcd leader changes produce a lot of churn during initial stages of CI jobs which cause a false positive and permafailing jobs to happen. This makes reading CI health more complicated and possibly affect customers that install OpenShift to get few alerts during bootstrap and early installation.


Version-Release number of selected component (if applicable):
4.11
4.10.z


How reproducible:

This failure can be seen in dozen jobs via CI search tool, like:

https://testgrid.k8s.io/redhat-openshift-ocp-release-4.10-informing#periodic-ci-openshift-multiarch-master-nightly-4.10-ocp-e2e-remote-libvirt-ppc64le
https://testgrid.k8s.io/redhat-openshift-ocp-release-4.10-informing#release-openshift-ocp-installer-e2e-aws-mirrors-4.10

Comment 4 errata-xmlrpc 2022-05-31 12:40:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.10.16 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:4754


Note You need to log in before you can comment on or make changes to this bug.