Bug 208044 - Request: Update compiz to latest release
Request: Update compiz to latest release
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2006-09-25 21:14 EDT by Stewart Adam
Modified: 2009-09-21 16:31 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-02 01:24:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshots showing the bug (42.38 KB, image/png)
2006-11-13 12:19 EST, drago01
no flags Details
srpm used (819.48 KB, application/x-redhat-package-manager)
2006-11-14 15:36 EST, drago01
no flags Details
enable cow by default (326 bytes, patch)
2006-11-15 03:46 EST, drago01
no flags Details | Diff
patch to fix desktop effects (576 bytes, patch)
2006-12-10 04:21 EST, drago01
no flags Details | Diff
0.3.6 (866.46 KB, application/x-redhat-package-manager)
2007-01-06 12:47 EST, drago01
no flags Details

  None (edit)
Description Stewart Adam 2006-09-25 21:14:36 EDT
Description of problem:
The Compiz in development is relatively outdated - 20060817 - Perhaps before FC6
 it should be updated to something more recent?

Version-Release number of selected component (if applicable):
compiz-0.0.13-0.27.20060817git.fc6

How reproducible:
-

Steps to Reproduce:
-  

Actual results:
-

Expected results:
-

Additional info:
Comment 1 Julian Sikorski 2006-10-04 07:14:49 EDT
fc6 is currently forzen, probably after release compiz will be updated. It would
be nice if the new version supported composite overlay window and metacity
themes (0.2.0 does).
Comment 2 Kristian Høgsberg 2006-10-04 11:03:43 EDT
Yup, the 0.2.0 release was a bit too close to the FC6 deadline, it won't make
it.  We will release an FC6 update as soon as possible.

By the way, the compiz in rawhide does support cow, it's in a patch in the RPM.
Comment 3 Stewart Adam 2006-10-04 17:02:28 EDT
Cool, looking forward to it... Compiz just keeps looking more and more promising!

Just on a side note, has the bug GUI Java applications showing a grey window
been fixed in 0.2.0?
Comment 4 drago01 2006-11-03 06:51:23 EST
(In reply to comment #3)
> Cool, looking forward to it... Compiz just keeps looking more and more promising!
> 
> Just on a side note, has the bug GUI Java applications showing a grey window
> been fixed in 0.2.0?
dunno but try export AWT_TOOLKIT="MToolkit" before running the java app or add
this to your .bashrc (thats what I did), and java apps will work fine with compiz

FC6 is now out, is a compiz update still planned?
if yes are they any packages to test yet?
Comment 5 Matthias Clasen 2006-11-12 11:54:20 EST
> FC6 is now out, is a compiz update still planned?
> if yes are they any packages to test yet?

You can try the compiz 0.3.2 packages in rawhide
Comment 6 Mihai Harpau 2006-11-12 13:11:39 EST
for me compiz 0.3.2 from rawhide does not work. also compiz-0.3.2.src.rpm does
not recompile under fc6+updates.

all on i915GM laptop (hp compaq nc6120)
Comment 7 Stewart Adam 2006-11-12 16:57:36 EST
I just tested 0.3.2, it needed some work on my part to get it working. I've
submitted two bugs on it already, but I'll summarize here:
- Desktop-effects doesn't kill window decorator on quitting
- Enabling desktop-effects stops all windows from refreshing their contents and
apparently continues to do so until another window manager is loaded, replacing
Compiz
- Using COW seems to fix the problem (when I launch manually from the CLI) but
as a result the effects seem laggier.
Comment 8 Julian Sikorski 2006-11-13 03:09:36 EST
desktop-effects program should be updated. Window decorator is now called
gtk-window-decorator, and there should be an option somewhere to enable COW.
Comment 9 drago01 2006-11-13 12:19:33 EST
Created attachment 141074 [details]
screenshots showing the bug

I tryed it on my fc6 sys (created a symlink
gnome-window-decorator->gtk-window-decorator) but the result was that there
where no close,maximize and minimize buttons (see screenshot)
also it was showing 4 desktops (workspaces) but I have configured 2 (fc6 compiz
works fine)
Comment 10 drago01 2006-11-13 12:20:35 EST
argh...
screenshot does not show the decoration at all (which is a other bug...)
Comment 11 Julian Sikorski 2006-11-14 13:19:50 EST
The problem with compiz not recompiling under fc6 and other metacity theme
issues may be caused by Patch117. It is called new-metacity-theme.patch, so it
may require new metacity theme support, which iirc isn't part of metacity 2.16.
If that's the case, BuuldRequires should be changed to reflect that.
Comment 12 drago01 2006-11-14 14:41:46 EST
if thats the case it might not work with metacity 2.16 which would explain my
problems above.
Comment 13 Julian Sikorski 2006-11-14 15:09:08 EST
Try dropping that patch and see if it helps.
Comment 14 drago01 2006-11-14 15:25:15 EST
dropping the patch fixes the build and the buttons (minimize,maximize and close
window) but the 4 workspaces problem still is there.
Comment 15 drago01 2006-11-14 15:29:48 EST
one other (minor problem) it shows the freedesktop but not the fedora logo on
top of the cube
Comment 16 drago01 2006-11-14 15:36:48 EST
Created attachment 141180 [details]
srpm used

ok viewport settings gets ignored if I use the settings menu, but work if I use
gconf editor.
change viewport uses a cube with 2 black sites and a black top if I use 2
viewports (fc6 compiz used a "paper" instead of the cube)
I also attached the src.rpm that I used (the same as the devel one - patch 117)
Comment 17 Julian Sikorski 2006-11-14 16:05:59 EST
As for fedora logo problem, iirc the schema file shall be patched as well. You
can select any file you want using appropriate gconf entry.
Comment 18 Stewart Adam 2006-11-14 16:55:58 EST
> which iirc isn't part of metacity 2.16.
It was happening on my computer...
$ rpm -q metacity
metacity-2.17.2-1.fc7
Or does it have to build with metacity v2.17?

Another small bug - It seems that Compiz as a whole is slower and also that
there's many more small errors - Many times I've seen little parts where effects
should be turn black, and other times a while window turns black until I change
it's position or click on a black part. Most easily reproduced by dragging
desktop icons / folders in Nautilus.
Comment 19 Julian Sikorski 2006-11-14 17:42:43 EST
You are running rawhide metacity.
Comment 20 Stewart Adam 2006-11-14 19:45:28 EST
Yes, but what I mean is I wonder if it's running metacity 2.17 that makes the
patch work or does it need to build on a system with metacity 2.17 - Because in
the first case, there would still be bugs in the patch as it was occurring when
I was running 2.17...
Comment 21 Julian Sikorski 2006-11-15 03:22:05 EST
Well, if you downloaded the binary rpm it was built on a system with metacity 2.17
Comment 22 drago01 2006-11-15 03:46:55 EST
Created attachment 141238 [details]
enable cow by default

(In reply to comment #18)
> > which iirc isn't part of metacity 2.16.
> It was happening on my computer...
> $ rpm -q metacity
> metacity-2.17.2-1.fc7
> Or does it have to build with metacity v2.17?
> 
> Another small bug - It seems that Compiz as a whole is slower and also that
> there's many more small errors - Many times I've seen little parts where
effects
> should be turn black, and other times a while window turns black until I
change
> it's position or click on a black part. Most easily reproduced by dragging
> desktop icons / folders in Nautilus.

could be caused by not using cow; try the starting compiz with --use-cow or try
the attched patch which enables it by default, like it was done in fc6 compiz.
Comment 23 Stewart Adam 2006-11-15 08:24:57 EST
Yup, it's better with cow enabled.
Comment 24 Matthias Clasen 2006-11-15 08:32:35 EST
Yes, Patch117 is necessary to build compiz against metacity 2.17, and creates a
runtime dependency against that metacity version.

Thanks for the cow patch, I probably overlooked that when I went through our
patches. I'll push a new build with that change.
Comment 25 Julian Sikorski 2006-11-15 10:42:42 EST
As for metacity 2.17 support, latest git compiz has added it in a less hacky way.
Comment 26 Didier 2006-11-16 07:40:24 EST
FWIW (apologies if this is off-topic) : 

An FC6 git srpm is available at
http://www.dmbr.ugent.be/~didier/compiz/compiz-0.3.3-20061116git_dmn.src.rpm.

1. Changes (with spec file based on 0.3.2-1.fc7) :
- Update to git 20061116
- Patch117 : drop metacity patch , replace with cow-default patch
- Modify aiglx-defaults.patch to comply with current git source

2. I bumped the version number to 0.3.3, to allow for out-of-the-box compilation
of the extra compiz plugins available at :
http://www.anykeysoftware.co.uk/compiz/plugins/
Anyone volunteering for compiz-extra-plugins in FC6 Extras ?

3. Very small artefact at lower left and right window corners, where the 1 px
rounded border is not drawn (rounded shadows are visible, though).

Overall appears to be quite stable.
Comment 27 Stewart Adam 2006-11-16 22:21:20 EST
Just compiled and installed this, it works perfectly.
Comment 28 Didier 2006-11-17 03:37:26 EST
Off-topic : a remaining issue preventing a levelled compiz end-user usability
compared to metacity is bug #216095 (no Workspaces/Viewport support, disables
"sticky" windows).

Comment 29 drago01 2006-11-17 11:18:54 EST
(In reply to comment #27)
> Just compiled and installed this, it works perfectly.

same here only thing:
the workspace selector does not work (have to use gconf-editor to change the
number of viewports)
Comment 30 drago01 2006-11-17 11:26:05 EST
(In reply to comment #28)
> Off-topic : a remaining issue preventing a levelled compiz end-user usability
> compared to metacity is bug #216095 (no Workspaces/Viewport support, disables
> "sticky" windows).
> 
> 

using the git snapshot rpm its possible to do rightclick->move to worksspace and
drag and drop in the pager works too.
sticky windows are still not possible :(
Comment 31 Didier 2006-11-17 11:35:45 EST
WRT comment #30 : both 'move to WS' (option not available) and 'pager D&D'
(doesn't work) do not function on my config (compiz-0.3.3-20061116git_dmn and
libwnck-2.16.0-4.fc6).
Did you restart X after compiz-0.3.3-20061116git_dmn installation ?

Comment 32 drago01 2006-11-17 11:53:53 EST
(In reply to comment #31)
> WRT comment #30 : both 'move to WS' (option not available) and 'pager D&D'
> (doesn't work) do not function on my config (compiz-0.3.3-20061116git_dmn and
> libwnck-2.16.0-4.fc6).
> Did you restart X after compiz-0.3.3-20061116git_dmn installation ?
> 
> 

yes it works using compiz-0.3.3-20061116git_dmn and libwnck-2.16.0-4.fc6 (I
restarted X).
NOTE: I am using 2 viewports/workspaces.
Comment 33 drago01 2006-11-18 05:30:19 EST
I tryed using the patched libwnck and recompiled compiz against it , always on
top worked.
the workspace switcher: it still the same as with the original libwnck (the
rightclick menu is there), but the drag and drop is broken it only works with
maximized windows (same with default libwnck) and moving a window to another
viewport my moving it over the edge does not work (It still stays on the same
viewport).
so the only improvement I get using the patched libwnck is always on top works
and the new menu for changing windows effects. Try filling a bug against libnck
to get this patches in.

The remaining compiz issues for me are:
* need patched libwnck to get always on top to work
* workspace switcher is broken (see above posts)
* performance issues with fullscreen gl apps:
there is a gconf option to that disables redirecting fullscreen apps to
offscreen pixmaps, but it does not work with cow; the cow window stays on to and
results into a black screen. Upstream should be working on fixing this.
* grouped windows issue:
http://lists.freedesktop.org/archives/compiz/2006-November/000867.html
Comment 34 Didier 2006-11-18 07:09:24 EST
Bug #216095 has already been filed against libwnck.

Our different functionality wrt viewports may be related to me running 6
viewports/workspaces.
Comment 35 drago01 2006-11-21 14:25:06 EST
(In reply to comment #33)

> * grouped windows issue:
> http://lists.freedesktop.org/archives/compiz/2006-November/000867.html

this is now fixed in git and should be part of 0.3.4 ;)

David also said that the gl perfomace issue will be fixed after 0.3.4 is out.
Comment 36 Didier 2006-11-23 07:12:53 EST
Latest compiz-0.3.4 now available at
http://www.dmbr.ugent.be/~didier/compiz/compiz-0.3.4-1_dmn.src.rpm.

Looks good, apart from the viewports/workspaces problem as stated in comment #31.
Comment 37 Stewart Adam 2006-11-23 10:08:08 EST
> http://www.dmbr.ugent.be/~didier/compiz/compiz-0.3.4-1_dmn.src.rpm
This is working great for me, but like you said the workspaces are acting
funny... I have 4 whole cubes instead of the workspace using my four cube faces!
Comment 38 Julian Sikorski 2006-11-24 11:13:45 EST
Are there any chances for fc6 branch?
Comment 39 Julian Sikorski 2006-11-30 14:51:17 EST
Just to clarify: rebuilt compiz-0.3.4-2.fc7.src.rpm package works just fine.
Comment 40 drago01 2006-12-10 04:17:06 EST
rawhide compiz rebuild same to work as good as the one in fc6 it only has two
issues:
1) destop-effects should use gtk-window-decorator not gnome-window-decorator
2) you need gconf to edit workspace/viewport count
Comment 41 drago01 2006-12-10 04:21:05 EST
Created attachment 143237 [details]
patch to fix desktop effects
Comment 42 Julian Sikorski 2006-12-10 04:33:08 EST
? The sed command in the spec file is supposed to change gnome-window-decorator
to gtk-window-decorator.
The bigger issue I have noticed with this small program is that is does not
handle active_plugins entry well. The default plugins list has got a bit shorter
since 0.1.163 version and as a result some of them are repeatedly missing (most
notably plane).
Comment 43 Stewart Adam 2007-01-05 16:17:12 EST
Is it just me or does 0.3.4 result in no window borders?
Comment 44 Julian Sikorski 2007-01-05 16:28:27 EST
Add decoration plugin and start gwd. Once again, DO NOT use desktop-effects.
It's not updated to internal compiz changes and does not work. Tweak the
settings with gconf-editor instead, it's not that hard.
Comment 45 Stewart Adam 2007-01-05 17:36:04 EST
Got it - I had to change 'Command' in compiz/plugins/decoration/allscreens/ to
'gtk-window-decorator', then disable using the Metacity themes in gwd.
Comment 46 drago01 2007-01-06 12:47:55 EST
Created attachment 144974 [details]
0.3.6

Here is a 0.3.6 srpm 
notes:
-a patch from ubuntu is included that fixes shodows on aiglx
-fedora logo patch broken
-kde window decorator disabled
-some patched are no longer needed  (->removed)
Comment 47 Eric Tanguy 2007-01-06 13:18:16 EST
why this package is not at least in updates/testing and after in updates ?
why this subject seems to be without the officiel maintainer ?
Comment 48 Paul Johnson 2007-01-12 13:16:21 EST
In the compiz email lists, I've seen claims that compiz has "absorbed" the
beryl-settings-manager program and called it "csm" to serve as a gui
configurator.  But in compiz 3.6, I don't find any program named "csm".  When I
run compiz, the only window decoration I can get is the ugly Metacity setup, and
none of the fancy decorations that you can get in Beryl are available.  

Can somebody clear up the situation?
Comment 49 Matthias Clasen 2007-01-19 14:13:51 EST
compiz 0.3.6 is in rawhide now.
Comment 50 Stewart Adam 2007-02-01 20:11:31 EST
Just a note for 0.3.6 - Sometimes the menus don't popup properly and the
"spring" if the popup is huge - eg they wobble like crazy.
Comment 51 Matthias Clasen 2007-02-02 01:24:21 EST
Closing this bug, since the latest compiz _is_ in rawhide. Any other issues
should be addressed in separate bugs.

Note You need to log in before you can comment on or make changes to this bug.