Bug 208047 - app segfaults when trying to load a db4 database
app segfaults when trying to load a db4 database
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gramps (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-25 22:24 EDT by Steven Usdansky
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-26 11:33:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Usdansky 2006-09-25 22:24:01 EDT
Description of problem:
Working with self-compiled gramps-2.1.95. Gramps crashes when loading or trying
to create a new db4 database.

Version-Release number of selected component (if applicable):
db4-4.3.29-9.fc6

How reproducible:
every time

Steps to Reproduce:
1. Start gramps
2a. File-> New to create a new datanase
or
2b. File->Open and select an existing gramps db4 database
  
Actual results:
Segmentation fault


Expected results:
new or existing database opened as requested


Additional info:
reverting to db4-4.3.29-7.fc6 fixes the problem

Terminal session of crash:
media/disk/mishpaha$ gramps mishpaha.grdb
Spelling checker is not installed
/usr/local/share/gramps/DisplayState.py:315: GtkWarning:
gtk_menu_attach_to_widget(): menu already attached to GtkImageMenuItem
  self.widget.set_menu(menu)
LPRDoc: Free true type fonts not found.
        Found Microsoft true type fonts. Will use them for now.
        These fonts are not free. 
        You are advised to switch to Free true type fonts
        INSTALL Free true type fonts
        from http://www.nongnu.org/freefont/
Trying to open: mishpaha.grdb ...
Type: GRAMPS database
Segmentation fault
Comment 1 Jindrich Novy 2006-09-26 04:10:05 EDT
Works for me with gramps-2.0.11.fc6 and db4-4.3.29-9.fc6 following your test case.

Reassigning to gramps to get more info from the gramps side.

Brian, are you able to reproduce that?
Comment 2 Brian Pepple 2006-09-26 10:19:01 EDT
I've got to reinstall Rawhide again, but once I do I'll try to reproduce this. 
It will probably be next week though, since I'm going to be fairly busy with
Ohio LinuxFest work this week.
Comment 3 Brian Pepple 2006-10-25 15:04:10 EDT
I'm unable to reproduce this error either, using either of the methods outlined.
 Steven, are you still experiencing it?  If so, do you have a sample db for me
to test with?
Comment 4 Brian Pepple 2006-11-16 16:52:55 EST
Ping?
Comment 5 Brian Pepple 2006-11-26 11:33:18 EST
Closing due to being unable to reproduce this.  Steven, If this is still a
problem, please re-open and attach some sample data for me to reproduce the bug.

Note You need to log in before you can comment on or make changes to this bug.