This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 208048 - No keyboard after install
No keyboard after install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-25 22:46 EDT by David Miller
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-03 16:06:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Miller 2006-09-25 22:46:05 EDT
Description of problem:

No keyboard during first-boot install dialogues.

Version-Release number of selected component (if applicable):


How reproducible:

Every time.

Steps to Reproduce:
1. Install on Thinkpad T41p laptop from rawhide boot.iso
2. Reboot into system after install
3. Try to type in name for "create user" dialogue
  
Actual results:

No response to keystrokes, although mouse works.

Expected results:

System responds to keystrokes.

Additional info:

Forcing the config dialogue to continue without creating a user
results in a seemingly hung system.  Logging in is possible,
but killing the X server via "/sbin/telinit 3" results in not
getting the console back.  Instead the X initialized screen
remains, a black background with the classic "X" mouse cursor.
The system seems to be otherwise find via remote ssh login.

Nothing strange appears to be in the xorg.conf file, for example
the keyboard section simply states:

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "us"
EndSection
Comment 1 David Miller 2006-09-26 00:56:30 EDT
I just hit the same problem on x86_64 with ATI Rage XL.  So the problem seems
to be generic and not tied to system type nor graphics card or anything
like that.
Comment 2 Adam Jackson 2006-10-03 12:15:02 EDT
Can you attach the X log file from an affected startup?
Comment 3 David Miller 2006-10-03 16:06:02 EDT
In the time it took for someone to look into this problem, I've
wiped those installations and installed yesterday's rawhide from
scratch and the problem no longer occurs.  So I'll close this.

Note You need to log in before you can comment on or make changes to this bug.