Bug 208078 - Banshee cannot rip from CD to ogg
Banshee cannot rip from CD to ogg
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: banshee (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-26 06:18 EDT by Kevin R. Page
Modified: 2007-12-27 18:21 EST (History)
1 user (show)

See Also:
Fixed In Version: F-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-27 18:21:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin R. Page 2006-09-26 06:18:42 EDT
Description of problem:
Banshee appears to rip CDs to Ogg - it creates files on the disk - but the files
would seem to be corrupt. Banshee (and other gstreamer based apps) fail to
decode the resulting Ogg files with:
"Playback Error: internal data flow error."
"Playback error: Could not decode stream."

Version-Release number of selected component (if applicable):
banshee-0.10.9-1..fc5

How reproducible:
Always

Steps to Reproduce:
1. Set CD import preference to Ogg
2. Rip CD with Ogg
3. Try to playback ripped files
  
Actual results:
Banshee cannot decode the ripped files

Expected results:
Banshee plays back ripped audio

Additional info:
It looks like this may be fixed upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=335211

The gst-launch pipeline suggested in the above bug report works for me; however
I've not managed to change the EncoderProfiles key successfully to work around
the bug (it's | delimited, but I can't see how to add the extra oggenc without
it breaking option passing).

The afflicted machine was a clean FC5 install, built within the last month, with
the latest updates applied immediately. I only mention this as I don't think
this has affected another machine upgraded from FC4 and then "slow" updated over
the life of FC5 (unfortunately I can't check that machine).
Comment 1 Christopher Aillon 2007-12-27 18:21:42 EST
Should be fixed in FC7 and later.

Note You need to log in before you can comment on or make changes to this bug.