Bug 20808 - Nvidia XServer dies
Nvidia XServer dies
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2000-11-13 21:14 EST by Neal D. Becker
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-11-19 19:41:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Neal D. Becker 2000-11-13 21:14:57 EST
I have RH7.0 with Creative 3D blaster TNT2 (riva).  It worked on RH6.2 using XFree86-3.3.6 OK.  The new Xserver doesn't work properly with it.  It is fine until it powers down the monitor.  This is a desktop, but it runs APMD so the clock will keep time correctly.  When it wakes up the Xserver dies.

This is *extremely* annoying.

I saw this same behaviour when I first tried XFree86-4.0, back when it first came out (pre RH7).  Later I installed the propietary driver (available directly from NVidia) and the problem was fixed.  After installing RH7 the problem is back.

I really don't want to install the proprietary version from NVidia if I can avoid it.
Comment 1 Mike A. Harris 2001-03-06 10:41:23 EST
It may be extremely annoying, however you can thank Nvidia for that.  Their
card does not have specs available, so all there is avail is the existing
frankendriver.  Your best bet is snagging an ATI Radeon, however that is likely
not in the question..  You might consider posting your server logs and config
to bugs@xfree86.org.  Mark Vojcovich may be able to help.

Other than that, the proprietary driver seems to work for people, however I
don't have any proprietary hardware to test with, nor would I be able to do
much with the card if I did - without specs.

Note You need to log in before you can comment on or make changes to this bug.