Bug 2080882 - Fix incorrectly logged error when searching for ovnkube master pod
Summary: Fix incorrectly logged error when searching for ovnkube master pod
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.10-rc3
Hardware: All
OS: All
low
low
Target Milestone: ---
: 4.10.z
Assignee: Martin Kennelly
QA Contact: Anurag saxena
URL:
Whiteboard:
Depends On: 2080876
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-05-02 09:20 UTC by Martin Kennelly
Modified: 2022-05-18 11:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 2080876
Environment:
Last Closed: 2022-05-18 11:51:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift ovn-kubernetes pull 1069 0 None open Bug 2080882: Fix incorrectly logged error when searching for ovnkube master pod 2022-05-02 09:22:40 UTC
Red Hat Product Errata RHBA-2022:2178 0 None None None 2022-05-18 11:51:13 UTC

Description Martin Kennelly 2022-05-02 09:20:57 UTC
+++ This bug was initially created as a clone of Bug #2080876 +++

Description of problem:
Before registering OVN northd metrics, we check to see if ovnkube
master is co-located on the same node and repeatedly check if it
is present because ovnkube node may start before ovnkube master.
This repeated checking only causes one error mode to occur which
is a timeout error and this is incorrectly logged as an error
confusing the user.
The only failure path to occur within 'checkPodRunsOnGivenNode' can
be seen with increased log level.


To verify this:
1. Grep the logs of the ovnkube-node container that isn't on a control plane node for the Error message 'Timed out while checking if OVNKube Master Pod runs'. You should not get a result.
2. Grep the logs of the ovnkube-node container that isn't on a control plane node for the Info message 'Not registering OVN North Metrics because OVNKube Master Pod was not found running on this'. You should get a result.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Grep the logs of the ovnkube-node container that isn't on a control plane node for the Error message 'Timed out while checking if OVNKube Master Pod runs'. 
2.
3.

Actual results:


Expected results:
Not error message but an Info message

Additional info:

Comment 6 errata-xmlrpc 2022-05-18 11:51:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.10.14 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:2178


Note You need to log in before you can comment on or make changes to this bug.