Bug 208097 - Invalid file descriptor in pwd(1)
Invalid file descriptor in pwd(1)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: valgrind (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-26 09:32 EDT by Kjartan Maraas
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.2.1-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-13 08:24:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2006-09-26 09:32:55 EDT
Description of problem:

Valgrind reports this:

==26071== Warning: invalid file descriptor -100 in syscall openat()
==26071==    at 0x3E17B6: __openat64_nocancel (openat.c:95)
==26071==    by 0x3E18EC: openat64 (openat.c:164)
==26071==    by 0x804B242: rpl_getcwd (getcwd.c:218)
==26071==    by 0x804AD1A: xgetcwd (xgetcwd.c:39)
==26071==    by 0x804925A: main (pwd.c:322)
--26071-- Caught __NR_exit; running __libc_freeres()
--26071-- REDIR: 0x3914A0 (memset) redirected to 0x4006580 (memset)

When running evolution. Could be that this is just a matter of teaching valgrind
about the special case of using -100 as a file descriptor in the openat case?
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Waugh 2006-09-26 09:37:21 EDT
No idea.  Jakub?
Comment 2 Jim Meyering 2006-09-26 09:41:11 EDT
Anyone know how to reproduce this?
Comment 3 Kjartan Maraas 2006-09-26 13:25:10 EDT
'valgrind -v -v --leak-check=full --num-callers=30 pwd' will do it here at least.
Comment 4 Tim Waugh 2006-12-13 08:16:54 EST
I can't reproduce this.  Does it still happen?

Changing component to valgrind since that's most likely where the problem is/was.
Comment 5 Jakub Jelinek 2006-12-13 08:24:27 EST
* Tue Sep 26 2006 Jakub Jelinek <jakub@redhat.com> 3.2.1-2
- fix openat handling (#208097)

Note You need to log in before you can comment on or make changes to this bug.