Bug 208125 - possible recursive locking detected (slock-AF_INET6)
possible recursive locking detected (slock-AF_INET6)
Status: CLOSED DUPLICATE of bug 205487
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Graf
Brian Brock
:
Depends On:
Blocks: FCMETA_LOCKDEP
  Show dependency treegraph
 
Reported: 2006-09-26 11:50 EDT by Mark Patton
Modified: 2014-06-18 04:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 19:38:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Patton 2006-09-26 11:50:50 EDT
Description of problem:

I've noticed the following warning in /var/log/messages:
=============================================
[ INFO: possible recursive locking detected ]
2.6.17-1.2630.fc6 #1
---------------------------------------------
setxkbmap/2360 is trying to acquire lock:
 (slock-AF_INET6){-+..}, at: [<c05b36ee>] sk_clone+0xd4/0x2d8

but task is already holding lock:
 (slock-AF_INET6){-+..}, at: [<dfb8e4d1>] tcp_v6_rcv+0x327/0x736 [ipv6]

other info that might help us debug this:
1 lock held by setxkbmap/2360:
 #0:  (slock-AF_INET6){-+..}, at: [<dfb8e4d1>] tcp_v6_rcv+0x327/0x736 [ipv6]

stack backtrace:
 [<c04051ee>] show_trace_log_lvl+0x58/0x171
 [<c0405802>] show_trace+0xd/0x10
 [<c040591b>] dump_stack+0x19/0x1b
 [<c043b915>] __lock_acquire+0x778/0x99c
 [<c043c0aa>] lock_acquire+0x4b/0x6d
 [<c061415b>] _spin_lock+0x19/0x28
 [<c05b36ee>] sk_clone+0xd4/0x2d8
 [<c05db24f>] inet_csk_clone+0xf/0x72
 [<c05ec08d>] tcp_create_openreq_child+0x1b/0x3a1
 [<dfb8d15d>] tcp_v6_syn_recv_sock+0x271/0x5b3 [ipv6]
 [<c05ec5e8>] tcp_check_req+0x1d5/0x2e9
 [<dfb8c449>] tcp_v6_do_rcv+0x142/0x340 [ipv6]
 [<dfb8e88b>] tcp_v6_rcv+0x6e1/0x736 [ipv6]
 [<dfb74a6f>] ip6_input+0x1c3/0x296 [ipv6]
 [<dfb74fdf>] ipv6_rcv+0x1d2/0x21f [ipv6]
 [<c05b9758>] netif_receive_skb+0x205/0x274
 [<c05bb0bc>] process_backlog+0x99/0xfa
 [<c05bb29f>] net_rx_action+0x9d/0x196
 [<c04293b7>] __do_softirq+0x78/0xf2
 [<c040668b>] do_softirq+0x5a/0xbe
 [<c04291ae>] local_bh_enable_ip+0xa9/0xcf
 [<c06140f9>] _spin_unlock_bh+0x25/0x28
 [<c05b24ef>] release_sock+0xb0/0xb8
 [<c05f4306>] inet_stream_connect+0x113/0x206
 [<c05b1452>] sys_connect+0x67/0x84
 [<c05b1ac4>] sys_socketcall+0x8c/0x186
 [<c0403faf>] syscall_call+0x7/0xb
DWARF2 unwinder stuck at syscall_call+0x7/0xb
Leftover inexact backtrace:



Version-Release number of selected component (if applicable):


How reproducible:

Very.

Steps to Reproduce:
1. Boot the laptop
2.
3.
  
Actual results:

Warning message.

Expected results:

No warning.


Additional info:

The stack trace seems to indicate a problem with the networking, but I'm able to
use wireless without a problem.
Comment 1 Dave Jones 2006-10-04 19:38:48 EDT

*** This bug has been marked as a duplicate of 205487 ***

Note You need to log in before you can comment on or make changes to this bug.