Bug 2081434 - Nautilus doesn't connect to samba network
Summary: Nautilus doesn't connect to samba network
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gvfs
Version: 35
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Ondrej Holy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2082240 2082586 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-05-03 17:41 UTC by Massimiliano M.
Modified: 2022-05-08 01:48 UTC (History)
16 users (show)

Fixed In Version: gvfs-1.48.1-3.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-08 01:48:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Massimiliano M. 2022-05-03 17:41:36 UTC
Description of problem: Nautilus doesn't connect to samba server


Version-Release number of selected component (if applicable):
samba client 4.15.7-0


How reproducible:
After install samba client 4.15.7-0 Nautilus doens't connect to samba server.

Steps to Reproduce:
1. install samba client 4.15.7-0
2. insert samba server address in Nautilus or click on bookmarked server
3.

Actual results: connection error

Expected results: it should connect and show files.


Additional info: My samba server is running on Raspberry Pi 4 (Raspbian). If I downgrade samba client to version 4.15.0 it works, Nautilus connect to samba server regularly.

Comment 1 Andreas Schneider 2022-05-04 06:12:39 UTC
https://gitlab.gnome.org/GNOME/gvfs/-/merge_requests/138

Comment 2 Ondrej Holy 2022-05-04 10:13:24 UTC
Ok, I will backport the mentioned fix also for F35. Just the problem is that the fix isn't obviously enough for all cases as per comments on https://gitlab.gnome.org/GNOME/gvfs/-/issues/619 and Bug 2068976. I'm just analyzing the logs and working on another fix. In the meantime, you can try to install the gvfs package from F36...

Comment 3 Fedora Update System 2022-05-05 10:59:47 UTC
FEDORA-2022-45c9d57591 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-45c9d57591

Comment 4 Ondrej Holy 2022-05-06 09:18:44 UTC
*** Bug 2082240 has been marked as a duplicate of this bug. ***

Comment 5 Alexander Bokovoy 2022-05-06 14:42:10 UTC
*** Bug 2082586 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2022-05-08 01:48:16 UTC
FEDORA-2022-45c9d57591 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.