Bug 208157 - /usr/sbin/ddcprobe does not find video care - other versions of ddcprobe do find it.
/usr/sbin/ddcprobe does not find video care - other versions of ddcprobe do f...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rhpxl (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-26 13:51 EDT by Jim Bradbury
Modified: 2008-03-26 12:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 12:05:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/xorg.conf (467 bytes, application/octet-stream)
2006-12-27 17:18 EST, Jim Bradbury
no flags Details
/var/log/Xorg.0.log (6.78 KB, application/octet-stream)
2006-12-27 17:21 EST, Jim Bradbury
no flags Details
untarred X log file (47.51 KB, text/plain)
2006-12-28 18:23 EST, Matěj Cepl
no flags Details
untarred X configuration file (948 bytes, text/plain)
2006-12-28 18:28 EST, Matěj Cepl
no flags Details
Results of running: kudzu -p -b pci -c video - .txt file (618 bytes, text/plain)
2007-01-02 10:59 EST, Jim Bradbury
no flags Details
ddcprobe fails to detect Matrox G450 card on different system (761 bytes, text/plain)
2007-01-02 11:12 EST, Jim Bradbury
no flags Details

  None (edit)
Description Jim Bradbury 2006-09-26 13:51:28 EDT
Description of problem:
/usr/sbin/ddcprobe does not find video card
or monitor.  
ddcprobe from several versions of Knoppix linux 
does find the video card -> Matrox Millenium P750 card


Version-Release number of selected component (if applicable):
Fedora Core 6 Test 3

How reproducible:
ddcprobe never finds card.

Steps to Reproduce:
1. run /usr/sbin/ddcprobe
2.
3.
  
Actual results:
Monitor autoprobe results
Monitor autoprobe failed.



Expected results:
Data on video card and monitor
ddcprobe from several versions of Knoppix linux all work
and find the card.


Additional info:
Comment 1 Jim Bradbury 2006-09-26 13:54:19 EDT
vesa driver does not work with Matrox Millenium P750 card in 
Fedora Core 6 Test 3.  It works with Fedora Core 5!!
Comment 2 Juha Tuomala 2006-12-27 11:13:34 EST
My ddcprobe doesn't list anything either. Nor I can't get picture - probably 
because xorg.conf relies on ddcprobe. No vesa nor radeon give anything, goes 
out of range of Dell LCD. I've got ATI dualhead card.

These used to work in fc5. :-(
Comment 3 Matěj Cepl 2006-12-27 16:28:26 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Jim Bradbury 2006-12-27 17:18:46 EST
Created attachment 144427 [details]
/etc/X11/xorg.conf
Comment 5 Jim Bradbury 2006-12-27 17:21:28 EST
Created attachment 144428 [details]
/var/log/Xorg.0.log

/var/log/Xorg.0.log
Comment 6 Jim Bradbury 2006-12-27 17:24:34 EST
The above two files are tar'ed and gzipped (.tgz)
Comment 7 Juha Tuomala 2006-12-27 17:33:30 EST
I digged this a littlebit and have a feeling that 'autodetection' mentioned in 
xorg-x11-drv-ati has something to do with that. Could not find my card 
in /usr/share/hwdata/videoaliases/radeon.xinf but adding it manually there 
didn't help. (got numbers with lspci -n)

Looks like ddcprobe uses kudzu, need to dig more later.
Comment 8 Juha Tuomala 2006-12-27 17:38:39 EST
perhaps someone could switch the version of this bug to released one, people 
would find this if filtering test releases out.
Comment 9 Matěj Cepl 2006-12-28 18:23:00 EST
Created attachment 144509 [details]
untarred X log file
Comment 10 Matěj Cepl 2006-12-28 18:28:51 EST
Created attachment 144511 [details]
untarred X configuration file
Comment 11 Chris Lumens 2007-01-02 10:15:55 EST
What are the results of running kudzu -p -b pci -c video?
Comment 12 Jim Bradbury 2007-01-02 10:59:48 EST
Created attachment 144645 [details]
Results of running: kudzu -p -b pci -c video - .txt file
Comment 13 Jim Bradbury 2007-01-02 11:12:24 EST
Created attachment 144646 [details]
ddcprobe fails to detect Matrox G450 card on different system
Comment 14 Juha Tuomala 2007-01-02 11:19:54 EST
# kudzu -p -b pci -c video
-
class: VIDEO
bus: PCI
detached: 0
desc: "ATI Technologies Inc R580 [Radeon X1900 XT] Secondary"
vendorId: 1002
deviceId: 7269
subVendorId: 1002
subDeviceId: 0b13
pciType: 1
pcidom:    0
pcibus: 84
pcidev:  0
pcifn:  1
-
class: VIDEO
bus: PCI
detached: 0
desc: "ATI Technologies Inc R580 [Radeon X1900 XT] Primary"
video.xdriver: radeon
vendorId: 1002
deviceId: 7249
subVendorId: 1002
subDeviceId: 0b12
pciType: 1
pcidom:    0
pcibus: 84
pcidev:  0
pcifn:  0
Comment 15 Juha Tuomala 2007-01-02 11:27:56 EST
that video.xdriver line comes from my own addition to radeon.xinf, I guess 
right place to it should be in vga.xinf as I understood that vesa is the only 
possible driver for this card.
Comment 16 zavandi 2007-03-17 05:00:00 EDT
I get the same error with a totally different graphics card and monitor.

And this gets printed in /var/log/messages every time I run ddcprobe:

python[8172]: obsolete kudzu ddcProbe called
Comment 17 Matthew Miller 2007-04-06 12:39:26 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 18 zavandi 2007-04-06 12:59:02 EDT
> You tried to change the Version field from fc6test3 to fc6, but only the owner
or submitter of the bug, or a autorized user, may change that field.

Ok, I can't.
But someone should...
Comment 19 Matthew Miller 2007-04-06 13:05:03 EDT
Done. Thanks.
Comment 20 Adam Jackson 2008-03-26 12:05:32 EDT
Not going to fix this one, sorry.  ddcprobe is going away.  Use 'kudzu -p -c
video' for video device detection.

Note You need to log in before you can comment on or make changes to this bug.