Bug 208172 - kernel dm snapshot: can't create more than 32 snapshots
kernel dm snapshot: can't create more than 32 snapshots
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity urgent
: ---
: ---
Assigned To: Milan Broz
:
: 191531 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-26 15:03 EDT by themoonseeker
Modified: 2013-02-28 23:04 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-13 13:03:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description themoonseeker 2006-09-26 15:03:09 EDT
Description of problem:
Impossible to create more than 32 snapshots

Version-Release number of selected component (if applicable):
LVM version: 2.02.06 (2006-05-12)
Library version: 1.02.08 (2006-07-17)
Driver version: 4.5.0

How reproducible:


Steps to Reproduce:
1. pvcreate /dev/sda10 
2. vgcreate vg /dev/sda10 
3. lvcreate -L150M -n original vg
4. mkfs -t ext3 /dev/vg/original
5. 33 times this command : 
lvcreate -s -L150M -n copy1 /dev/vg/original
lvcreate -s -L150M -n copy2 /dev/vg/original
...
lvcreate -s -L150M -n copy32 /dev/vg/original
  
Actual results:
root@B03:/diplome# lvcreate -s -L150M -n copy32 /dev/vg/original
  Rounding up size to full physical extent 152.00 MB
  device-mapper: reload ioctl failed: Cannot allocate memory
  Failed to suspend origin original

Expected results:
root@B03:/diplome# lvcreate -s -L150M -n copy32 /dev/vg/original 
  Rounding up size to full physical extent 152.00 MB
  Logical volume "copy32" created

Additional info:
Kernel : uname -r
2.6.16
Comment 1 Milan Broz 2006-12-04 04:17:36 EST
Known limitation of DM-IO code waiting for new implementation of dm-io (still
under review)...
Comment 2 Milan Broz 2007-03-14 13:26:30 EDT
Correcting version & component.
Comment 3 Milan Broz 2007-06-13 12:10:53 EDT
*** Bug 191531 has been marked as a duplicate of this bug. ***
Comment 4 Milan Broz 2007-06-13 13:03:39 EDT
This problem is fixed in stable kernel rc releases 2.6.22-rc

Because rawhide uses rc patches, this is already fixed - creating 50 snapshots
with kernel 2.6.21-1.3218.fc8 works ok.

Note You need to log in before you can comment on or make changes to this bug.