Bug 2081720 - plot3d in terminal opens empty html page
Summary: plot3d in terminal opens empty html page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sagemath
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paulo Andrade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-05-04 13:21 UTC by Vegard Lima
Modified: 2022-06-16 01:20 UTC (History)
1 user (show)

Fixed In Version: sagemath-9.6-1.fc37 sagemath-9.6-1.fc36
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-06-07 17:43:14 UTC
Type: Bug


Attachments (Terms of Use)

Description Vegard Lima 2022-05-04 13:21:51 UTC
Description of problem:

When running sage in a terminal plot3d does not work.

Version-Release number of selected component (if applicable):

sagemath-9.4-2.fc35.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. Open sage in terminal $ sage
2. sage: var('x,y')
3. sage: plot3d(x^2+y^2, (x,-1,1), (y,-1,1))

Actual results:

A blank page is opened in the browser.

Expected results:

A page with a 3d-plot should open in the browser.

Additional info:

The html-file that is opened in the browser contains the line:
<script src="/usr/share/sagemath/threejs-sage/r122/three.min.js"></script>

The problem is that three.min.js is actually installed in:
/usr/share/sagemath/threejs/build/three.min.js

If a create the directory threejs-sage/r122 and make a symbolic link
to the three.min.js file there everything works as expected.

Comment 1 Fedora Update System 2022-06-07 17:38:52 UTC
FEDORA-2022-3193745ede has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-3193745ede

Comment 2 Fedora Update System 2022-06-07 17:43:14 UTC
FEDORA-2022-3193745ede has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 3 Fedora Update System 2022-06-07 21:40:01 UTC
FEDORA-2022-0326bd55bf has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-0326bd55bf

Comment 4 Fedora Update System 2022-06-08 01:14:23 UTC
FEDORA-2022-0326bd55bf has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-0326bd55bf`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-0326bd55bf

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2022-06-16 01:20:30 UTC
FEDORA-2022-0326bd55bf has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.