Bug 208180 - Greeter always shown in english even with Norwegian set via s-c-language
Summary: Greeter always shown in english even with Norwegian set via s-c-language
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-26 20:11 UTC by Kjartan Maraas
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-27 04:15:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kjartan Maraas 2006-09-26 20:11:17 UTC
Description of problem:
I installed my system from a rawhide iso earlier in the cycle and didn't choose
a different language at the time. After the install was finished I chose
Norwegian in the gdm login dialog, and later still I changed the system language
with system-config-language. I still can't get the gdm greeter to show anything
but english though.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Matthias Clasen 2006-09-27 04:15:35 UTC
Turns out that gdm simply does not have a Norwegian translation...
This shoud be handled upstream.

Comment 2 Kjartan Maraas 2006-09-27 06:28:57 UTC
But of course it does:

[kmaraas@rivendell gdm2]$ rpm -ql gdm | grep nb
/usr/share/locale/nb/LC_MESSAGES/gdm.mo

I should know, I put it there in the first place. No idea why gdm doesn't pick
it up in rawhide though. As I said on IRC, if I run /usr/libexec/gdmgreeter
directly I get norwegian text (with DOING_GDM_DEVELOPMENT=1 set) 


Note You need to log in before you can comment on or make changes to this bug.