Bug 208195 - kcp command fails due to lack of scp
kcp command fails due to lack of scp
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-26 17:40 EDT by Valdis Kletnieks
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.101-53.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-27 07:45:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2006-09-26 17:40:11 EDT
Description of problem:
/sbin/mkdumprd only includes the pieces needed for scp if a net: type
destination is found /etc/kdump.conf.  As a result, 'kcp --local /proc/vmcore
/mnt/var...' fails because the execve of 'scp' fails.

Version-Release number of selected component (if applicable):
kexec-tools-1.101-51.fc6

How reproducible:
Create a /etc/kdump.conf that only contains:

ext3 /dev/something_valid
default reboot

Steps to Reproduce:
1.
2.
3.
  
Actual results:
kcp creates the directory correctly.  It then gets to the execlp at kcp.c:168
and dies because scp and its requisites weren't included in the initrd.

Expected results:


Additional info:
In some environments, you may need to take crash dumps locally, without talking
to the network (stand-alone machines, or even machines on the net that don't
have a valid place to NFS or SCP a large file to)...

In addition, the "dest" parameter in the kcp.c code is a directory spec, which
is just a bug waiting to happen to somebody who tries to provide their own 'scp'
that just does a local copy (you need to sprintf(new,"%s/vmcore",dest); or
similar to get a filename useful for writing (as I discovered the hard way while
trying to create a local workaround.. ;)
Comment 1 Neil Horman 2006-09-27 07:45:52 EDT
I've re-written kexec-tools to use busybox, so kcp is no longer needed.  ssh
should be included in that initrd as well.  Version -53.fc6 has all these changes

Note You need to log in before you can comment on or make changes to this bug.