Bug 208198 - Rendering problem for malayalam consonant RA (U+0D30)
Rendering problem for malayalam consonant RA (U+0D30)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
6
All Linux
high Severity high
: ---
: ---
Assigned To: Behdad Esfahbod
: i18n
Depends On:
Blocks: FC6Update 209095
  Show dependency treegraph
 
Reported: 2006-09-26 18:14 EDT by Rahul Bhalerao
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: pango-1.14.6-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-22 20:59:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for indic-ot-class-table (976 bytes, patch)
2006-09-26 18:16 EDT, Rahul Bhalerao
no flags Details | Diff
Patch for indic-ot.c (1.20 KB, patch)
2006-09-26 18:17 EDT, Rahul Bhalerao
no flags Details | Diff

  None (edit)
Description Rahul Bhalerao 2006-09-26 18:14:34 EDT
Description of problem:

The rendering of conjuncts formed with u0D30 is wrong. Also, u0D30 when
followed by a postbase form splits the original combination and makes it own
conjunct with 
the last consonant. i.e. Combination e.g.
 u0d15 + u0d4d + u0d2f

cannot be followed by u0d30.

Version-Release number of selected component (if applicable):
1.14.x

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rahul Bhalerao 2006-09-26 18:16:09 EDT
Created attachment 137178 [details]
Patch for indic-ot-class-table

Modifies the mlymCharClasses[] to change the class of u0d30 from _pb to _cn.
u0d30 doesnt have a post base form. Its rendering is similar to u0d31.
Comment 2 Rahul Bhalerao 2006-09-26 18:17:11 EDT
Created attachment 137179 [details]
Patch for indic-ot.c

Since u0d30 and u0d31 have similar rendering, same function is used for u0d30
as for u0d31.
Comment 3 Leon Ho 2006-09-28 05:22:43 EDT
Thanks for the patch Rahul, reassign to Behdad to include into FC6 package.
Comment 4 Matthias Clasen 2006-10-06 10:12:15 EDT
I don't think this is blocking issue
Comment 5 Leon Ho 2006-10-07 02:18:39 EDT
IMHO, it is a blocking issue, this bug will lean to large amount of character
compositions failed for Malayalam users on *any* GNOME applications, which is
our new official language for FC6. Patch is available. Please reconsider this
decision.
Comment 7 Matthias Clasen 2006-10-13 00:01:49 EDT
This will be fixed when we push pango 1.14.6 out as an update
Comment 8 Liang Zhang 2006-10-15 22:34:39 EDT
The pango of redhat cvs has already been 1.14.6 .
This bug can be closed.
Comment 9 Leon Ho 2006-10-15 23:47:26 EDT
Need to keep this bug open to track until the package is built into FC6-Updates.
Comment 10 Fedora Update System 2006-10-24 16:22:56 EDT
pango-1.14.6-2.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 11 Fedora Update System 2006-10-25 11:53:09 EDT
pango-1.14.6-2.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 12 Fedora Update System 2006-10-30 16:43:34 EST
pango-1.14.6-2.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.