Bug 208207 - RFE: swap partition and hibernate
RFE: swap partition and hibernate
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-26 21:40 EDT by Ronald Warsow
Modified: 2015-03-04 20:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-23 11:27:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald Warsow 2006-09-26 21:40:31 EDT
Description of problem:
starting pm-hibernate from runlevel 5 *without* an active swap partition is
possible. box doesn't hibernates (quit clear), but the user doesn't see any
warnings (runlevel 5), screen goes black and box seems to hang.

Version-Release number of selected component (if applicable):
seen in FC5.

How reproducible:
ever

Steps to Reproduce:
1. deactivate swap partition (maybe a wrong label)
2. reboot and switch to runlevel 5
3. pm-hibernate from runlevel 5
  
Actual results:
box seems to hang and seems to be unable to hibernate

Expected results:
user should see a warning or he/she should not be able to select pm-hibernate

Additional info:
Comment 1 Phil Knirsch 2007-01-23 11:27:27 EST
Uhm, you need a swap space in order to hibernate, thats basically the
requirement for it to work.

Read ya, Phil
Comment 2 Ronald Warsow 2007-01-24 02:48:21 EST
really ?
clever boy !
and what does a less tech. user report, if he/she canceled his/her swap
partition and tries to hibernate ?

"steal" somebody's swap partition and wait when he want's to hibernate.
ask him/her what he/she want's to write to the mail lists or bz.

the *menu entries* (gnome) say he/she can, regardless if the swap partition exists.
what does that user think ?????,
sitting in front of an black screen -for some long time...- 

this was an RFE to prevent that *and* unnessary bug reports, THAT's all.

but you didn't read it anyway... 

what do you mean, what do i think now ????? -sitting in front of your comment -

Note You need to log in before you can comment on or make changes to this bug.