Bug 208213 - Firefox Does Not Work On a Network that Does Not Support TCP DNS
Firefox Does Not Work On a Network that Does Not Support TCP DNS
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-26 22:47 EDT by Jonathan Steffan
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: firefox-2.0.0.4-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-19 14:06:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Steffan 2006-09-26 22:47:48 EDT
Description of problem:
Firefox stops working (after some update) when no tcp dns is available on the
network.

Version-Release number of selected component (if applicable):
firefox-1.5.0.7-1.fc5


How reproducible:
On affected systes, always.

Steps to Reproduce:
1.Install Fedora on a machine with UDP only DNS support
2.Update Fedora
3.Run firefox to find that it has stopped working
  
Actual results:
Firefox does not work. All other dns does, including other browsers.

Expected results:
Firefox should work.

Additional info:
It was determined that the network (in the test case the Qwest DSL actiontec
modem) does not support any tcp DNS. However, udp must have worked at some point
because the firefox that ships with fedora core 5 seems to work fine on these
networks.

dig @modem +notcp redhat.com (works)
dig @modem +tcp redhat.com (does not work)
Comment 1 Matěj Cepl 2007-07-18 13:31:16 EDT
Fedora Core 5 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora Core 6, or
Fedora 7, or Rawhide)? If this issue turns out to still be reproducible, please
let us know in this bug report.  If after a month's time we have not heard back
from you, we will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.
Comment 2 Jonathan Steffan 2007-07-19 03:53:25 EDT
Yes, I will try later today.
Comment 3 Jonathan Steffan 2007-07-19 12:59:02 EDT
firefox-2.0.0.4-2.fc7 is tested and working when there is no TCP DNS on network.
Comment 4 Matěj Cepl 2007-07-19 14:06:29 EDT
Thank you very much, that's nice to hear. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.