Bug 20822 - sendmail removes duplicate headers
sendmail removes duplicate headers
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-14 03:00 EST by Alexandre Oliva
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-04 11:53:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2000-11-14 03:00:57 EST
It seems that sendmail needlessly (?) removes duplicate To: and Cc: headers
from messages it feeds to procmail.  I'd prefer that it left them
untouched, as people (myself included) have made it an habit to have more
than one Cc: line.  Also, some of my mail-splitting rules match
mailing-list names in these fieds and, when sendmail removes the lines that
happen to contain the mailing-list name, I get the message in the wrong folder.

I've noticed that the queue file still contains duplicate headers, and,
when sendmail forwards messages via SMTP, it won't discard duplicates.  By
replacing procmail with a shell-script that cat all of its stdin in a
temporary file and then execed the actual procmail so that it reads from
the temporary file, I've noticed that what sendmail feeds to procmail does
NOT contain the duplicates, so it is not procmail that is removing duplicates.

I couldn't find any mention of this new (mis)feature in the release notes
of sendmail, nor any configuration flags to revert to the original
behavior, so this may well not be something specific to Red Hat Linux 7's
default configuration, but I thought I'd report it here just in case.

I've just verified that the problem does not occur with a hand-built
sendmail 8.11.1, so either the problem was fixed in 8.11.1 or it is
specific to Red Hat Linux.  Please verify.
Comment 1 Florian La Roche 2001-01-04 11:53:29 EST
I have checked the changes and this was indeed fixed in
8.11.1. I have just updated to 8.11.2 today. Thanks for
this bug-report.

Note You need to log in before you can comment on or make changes to this bug.