Bug 208220 - Please translate "About Fedora" desktop file
Summary: Please translate "About Fedora" desktop file
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
(Show other bugs)
Version: devel
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Release Notes Tracker
QA Contact: Karsten Wade
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC6Blocker
TreeView+ depends on / blocked
 
Reported: 2006-09-27 04:55 UTC by Matthias Clasen
Modified: 2007-04-27 17:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-27 17:49:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
about-gnome.desktop.in (287 bytes, text/plain)
2006-09-27 04:58 UTC, Matthias Clasen
no flags Details
about-gnome.desktop (594 bytes, application/x-desktop)
2006-09-27 04:59 UTC, Matthias Clasen
no flags Details

Description Matthias Clasen 2006-09-27 04:55:59 UTC
Here is a desktop.in file and a translated .desktop file that was generated
by taking the existing titles from the translated omf files.

Comment 1 Matthias Clasen 2006-09-27 04:58:09 UTC
Created attachment 137200 [details]
about-gnome.desktop.in

Comment 2 Matthias Clasen 2006-09-27 04:59:30 UTC
Created attachment 137201 [details]
about-gnome.desktop

Comment 3 Paul W. Frields 2006-10-10 13:09:05 UTC
We have translated copies in fedora-release-notes-6-2, but the translated
versions don't show up properly.  Only the standard (non-localized) "Exec="
string is being used, and not "Exec[<LANG>]=".  Even though the "Name" strings
are localized (and appear properly translated in the Main Menu), they all lead
to the C locale (English) document.  This apparently doesn't surface with other
menu entries because they are pulling their strings programmatically from the
.mo locale stores.  Any help or guidance would be appreciated.

Comment 4 Jesse Keating 2006-11-08 13:27:19 UTC
how did we do on this for FC6?

Comment 5 Jesse Keating 2006-12-15 17:18:05 UTC
Ping?

Comment 6 Matthias Clasen 2006-12-15 18:49:28 UTC
Odd, I don't recall why we would have chosen this approach with Exec[<locale>].
It doesn't work, because Exec is defined as a string, not a localestring, in the
desktop entry spec.

For the RH deployment guide, we did things differently. We have a single exec line:

Exec=yelp ghelp:Deployment_Guide

and then we link the deployment guide into the /usr/share/gnome/help hierarchy
so that yelp can find it:

/usr/share/gnome/help/Deployment_Guide/en --> /usr/share/doc/Deployment_Guide-en

This requires that the toplevel file is named the same as the directory, since
ghelp:Deployment_Guide causes yelp to look for

/usr/share/gnome/help/Deployment_Guide/<locale>/Deployment_Guide.xml


Would this approach be possible for about fedora ?

Comment 7 Paul W. Frields 2007-04-27 17:49:05 UTC
I don't know how I lost track of this bug, so I apologize to all involved.  This
is fixed in Docs Rawhide now and should make F7 final release.


Note You need to log in before you can comment on or make changes to this bug.