Bug 2082337 - python-google-cloud-bigquery: FTBFS in Fedora Rawhide
Summary: python-google-cloud-bigquery: FTBFS in Fedora Rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-google-cloud-bigquery
Version: 35
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Major Hayden 🤠
QA Contact:
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F35FTBFS F36FTBFS F37FTBFS
TreeView+ depends on / blocked
 
Reported: 2022-05-05 19:57 UTC by Ben Beasley
Modified: 2022-05-16 02:04 UTC (History)
1 user (show)

Fixed In Version: python-google-cloud-bigquery-2.34.3-1.fc36 python-google-cloud-bigquery-2.34.3-1.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-16 01:07:49 UTC
Type: Bug


Attachments (Terms of Use)

Description Ben Beasley 2022-05-05 19:57:16 UTC
Description of problem:
Package python-google-cloud-bigquery fails to build from source in Fedora Rawhide.

Version-Release number of selected component (if applicable):
2.30.1-2.fc36

Steps to Reproduce:
koji build --scratch f37 python-google-cloud-bigquery-2.30.1-2.fc36.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-google-cloud-bigquery

I just enabled Koschei for the package, but it hasn’t picked up the FTBFS yet. Here’s a manual scratch build:

https://koji.fedoraproject.org/koji/taskinfo?taskID=86692460

> =========================== short test summary info ============================
> FAILED tests/unit/test_client.py::TestClient::test__initiate_resumable_upload
> FAILED tests/unit/test_client.py::TestClient::test__initiate_resumable_upload_mtls
> FAILED tests/unit/test_client.py::TestClient::test__initiate_resumable_upload_with_retry
> =========== 3 failed, 1616 passed, 263 skipped, 1 warning in 14.69s ============

I ran into this problem while checking dependent packages, including those that use python3dist(google-api-core[grpc]), for an upcoming grpc update in Rawhide.

The differences between the expected and actual headers look pretty trivial. I see:

> 'content-type': 'application/json; charset=UTF-8'

instead of

> 'content-type': 'application/json'

Comment 1 Ben Beasley 2022-05-05 20:01:23 UTC
It looks like the same thing happens in F35 and F36, too.

Comment 2 Major Hayden 🤠 2022-05-06 12:34:42 UTC
Thanks, Ben! I am taking a look this morning.

Comment 3 Fedora Update System 2022-05-06 12:55:07 UTC
FEDORA-2022-fe16cbb6a1 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-fe16cbb6a1

Comment 4 Fedora Update System 2022-05-06 12:55:07 UTC
FEDORA-2022-200ec8f5c8 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-200ec8f5c8

Comment 5 Ben Beasley 2022-05-06 13:14:28 UTC
Awesome, thanks!

Unsurprisingly, it builds in the grpc COPR now, too: https://copr.fedorainfracloud.org/coprs/music/grpc/package/python-google-cloud-bigquery/

Comment 6 Fedora Update System 2022-05-08 03:06:22 UTC
FEDORA-2022-200ec8f5c8 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-200ec8f5c8`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-200ec8f5c8

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2022-05-08 03:26:57 UTC
FEDORA-2022-fe16cbb6a1 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-fe16cbb6a1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-fe16cbb6a1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2022-05-16 01:07:49 UTC
FEDORA-2022-200ec8f5c8 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2022-05-16 02:04:42 UTC
FEDORA-2022-fe16cbb6a1 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.