Bug 208237 - /etc/rndc.conf already includes a key since 9.2.4-14_EL3, making rndc unusable without fixing
/etc/rndc.conf already includes a key since 9.2.4-14_EL3, making rndc unusabl...
Status: CLOSED DUPLICATE of bug 202012
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: bind (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Martin Stransky
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-27 05:49 EDT by Peter Bieringer
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-04 08:39:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2006-09-27 05:49:16 EDT
Description of problem:
There is a problem in the RPM of 9.2.4-14_EL3, /etc/rndc.conf includes a key
instead the include statement. Something was going wrong during packaging from
-7 to -14 and QA hasn't detected?

Version-Release number of selected component (if applicable):
bind-9.2.4-14_EL3

How reproducible:
After clean installation

Steps to Reproduce:
1. install RHEL3U8
2. install bind
3. try to use rndc
  
Actual results:
Won't work, key mismatch.

Error message:
Sep 27 11:36:43 server named[1305]: invalid command from 127.0.0.1#37326: bad auth

Expected results:
No key mismatch, use of common key required like in older packages.


Additional info:

Diff between working -7 and not working -14:

$ diff -ur bind-9.2.4-7_EL3 bind-9.2.4-14_EL3
diff -u -ur bind-9.2.4-7_EL3/rndc.conf bind-9.2.4-14_EL3/rndc.conf
--- bind-9.2.4-7_EL3/rndc.conf  2005-01-04 20:49:03.000000000 +0100
+++ bind-9.2.4-14_EL3/rndc.conf 2006-04-05 01:22:14.000000000 +0200
@@ -23,12 +23,14 @@

 options {
         default-server  localhost;
-        default-key     "rndckey";
+        default-key     "key";
 };

 server localhost {
-        key     "rndckey";
+        key     "key";
 };

-include "/etc/rndc.key";
-
+key "key" {
+        algorithm       hmac-md5;
+        secret "c3Ryb25nIGVub3VnaCBmb3IgYSBtYW4gYnV0IG1hZGUgZm9yIGEgd29tYW4K";
+};
diff -u -ur bind-9.2.4-7_EL3/rpm-qp--scripts.txt
bind-9.2.4-14_EL3/rpm-qp--scripts.txt
--- bind-9.2.4-7_EL3/rpm-qp--scripts.txt        2006-09-27 11:27:25.000000000 +0200
+++ bind-9.2.4-14_EL3/rpm-qp--scripts.txt       2006-09-27 11:27:31.000000000 +0200
@@ -16,7 +16,7 @@
          mv -f /etc/rndc.key.tmp /etc/rndc.key
        fi
        if [ ! -s /etc/named.conf ]; then
-          echo -e '// Default named.conf generated by install of
bind-'9.2.4'-'7_EL3'\noptions {\n\tdirectory "/var/named";\n\tdump-file
"/var/named/data/cache_dump.db";\n\tstatistics-file
"/var/named/data/named_stats.txt";\n};\ninclude "/etc/rndc.key";\n' >
/etc/named.conf;
+          echo -e '// Default named.conf generated by install of
bind-'9.2.4'-'14_EL3'\noptions {\n\tdirectory "/var/named";\n\tdump-file
"/var/named/data/cache_dump.db";\n\tstatistics-file
"/var/named/data/named_stats.txt";\n};\ninclude "/etc/rndc.key";\n' >
/etc/named.conf;
        fi;
        if [ -x /sbin/restorecon ]; then
           #
Comment 1 Peter Bieringer 2006-09-27 05:59:13 EDT
BTW: 9.2.4-16.EL4 has the same problem.
Comment 2 Martin Stransky 2006-10-01 16:24:23 EDT
It's a dupe of Bug 203070
Comment 3 Martin Stransky 2006-10-04 08:39:21 EDT

*** This bug has been marked as a duplicate of 202012 ***

Note You need to log in before you can comment on or make changes to this bug.