Bug 208262 - After upgrade to net-snmp-5.1.2-11.EL4.7, mrtg on RHEL 3 has problems reaching eth statistics
After upgrade to net-snmp-5.1.2-11.EL4.7, mrtg on RHEL 3 has problems reachin...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-snmp (Show other bugs)
4.4
ia32e Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-27 09:36 EDT by David Kostal
Modified: 2007-11-16 20:14 EST (History)
2 users (show)

See Also:
Fixed In Version: net-snmp-5.1.2-11.EL4.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 10:15:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kostal 2006-09-27 09:36:17 EDT
Description of problem:
After upgrade net-snmp on RHEL 4.4/ia32e from net-snmp-5.1.2-11.EL4.6 +
net-snmp-libs-5.1.2-11.EL4.6 to 5.1.2-11.EL4.7, mrtg running on RHEL 3/ia32e
sometimes timeouts or get no info for in- and out- packets on eth0.

After downgrading to 5.1.2-11.EL4.6 everything works smooth again.

Version-Release number of selected component (if applicable):
net-snmp-5.1.2-11.EL4.7
net-snmp-libs-5.1.2-11.EL4.7


How reproducible:
in 4 out of 5 cases

Steps to Reproduce:
1. upgrade net-snmp and net-snmp-utils to 5.1.2-11.EL4.7 on RHEL 4
2. run mrtg (tested only on RHEL 3) to check above upgraded host
3. 
  
Actual results:
mrtg takes too long to process, and finally ends up saying:
# LANG=C /usr/bin/mrtg /etc/mrtg/mrtg.cfg.dk
SNMP Error:
no response received
SNMPv1_Session (remote host: "10.1.1.65" [10.1.1.65].161)
                  community: "public"
                 request ID: -1884720729
                PDU bufsize: 8000 bytes
                    timeout: 2s
                    retries: 5
                    backoff: 1)
 at /usr/bin/../lib64/mrtg2/SNMP_util.pm line 458
SNMPGET Problem for ifDescr.2 ifInOctets.2 ifDescr.2 ifOutOctets.2 on
public@10.1.1.65
 at /usr/bin/mrtg line 1678
WARNING: Could not match host:'public@10.1.1.65' ref:'Descr' key:'eth0'
WARNING: skipping because at least the query for ifDescr.2 on  10.1.1.66 did not
succeed
WARNING: no data for ifInOctets&ifOutOctets:public@10.1.1.66. Skipping further
queries for Host 10.1.1.66 in this round.
ERROR: Target[h-wl0_eth0][_IN_] ' $$target[1]{$mode} ' did not eval into defined
data
ERROR: Target[h-wl0_eth0][_OUT_] ' $$target[1]{$mode} ' did not eval into
defined data
ERROR: Target[h-wl1_eth0][_IN_] ' $$target[3]{$mode} ' did not eval into defined
data
ERROR: Target[h-wl1_eth0][_OUT_] ' $$target[3]{$mode} ' did not eval into
defined data
#

On h-wl0 and h-wl1 machines (running upgraded net-snmp) are these error in syslog:
Sep 27 14:08:10 h-wl0 snmpd[6805]: truncating integer value to 32 bits 
Sep 27 14:08:20 h-wl0 last message repeated 5 times

Expected results:
no error message

Additional info:
relevant part of mrtg.cfg.dk
WorkDir: /var/www/html/mrtg/
LogFormat: rrdtool

Target[h-wl0_eth0]: \eth0:public@10.1.1.65
MaxBytes[h-wl0_eth0]: 125000000
title[h-wl0_eth0]: title

Target[h-wl1_eth0]: \eth0:public@10.1.1.66
MaxBytes[h-wl1_eth0]: 125000000
title[h-wl1_eth0]: title
Comment 1 Sharif Nassar 2006-10-09 21:30:40 EDT
We've got the same problem with RHEL 4.3 host running cricket querying servers
at RHEL 4.4

Downgrading to the latest 4.3 versions of net-snmp-* on the 4.4 hosts solves the
problem... inelegantly.
Comment 2 Chris Adams 2006-10-09 22:21:06 EDT
This appears to be a duplicate of bug 202584.  I see the problem with Cricket,
and IIRC MRTG uses the SNMP_Session perl module.

However, I only see the problem when querying a 64 bit RHEL4.4.  Querying a 32
bit system works okay.  The system running Cricket is a 64 bit server (but that
shouldn't affect a perl module - SNMP_Session is written purely in perl).
Comment 3 Jan Safranek 2007-06-04 10:15:36 EDT
Thix bug shall be already fixed in current RHEL-4.5 release. Any net-snmp >=
5.1.2-11.EL4.9 should be OK.

Note You need to log in before you can comment on or make changes to this bug.