Bug 208287 - Pull patches from kexec-tools upstream (Read /proc/kcore for kernel addr and size)
Summary: Pull patches from kexec-tools upstream (Read /proc/kcore for kernel addr and ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Neil Horman
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 207598
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-27 17:37 UTC by Vivek Goyal
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-13 17:10:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
omnibus patch of viveks requested changes to go in when bz 207598 clears (32.95 KB, patch)
2006-09-29 16:57 UTC, Neil Horman
no flags Details | Diff

Description Vivek Goyal 2006-09-27 17:37:10 UTC
Description of problem:

Relocatable kernel support was included in RHEL5 Beta1. For that kexec-tools
also had to be modified to generated the ELF headers properly in output
vmcore file. Due to lack of time a stop gap fix was put in kexec-tools.

Now a more proper fix is available for kexec-tools which should be included.

Version-Release number of selected component (if applicable):

RHEL5-Beta2

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Neil Horman 2006-09-29 16:13:58 UTC
I'm running into some hard reboot problems while testing the patch.  I've sent a
note to the reporter asking if he has any insight.

Comment 2 Neil Horman 2006-09-29 16:49:37 UTC
Vivek has shown me what problem is causing this (as described in bz 207598). 
Given that this will break kexec/kdump functionality with kernels prior to
kernel version that had this problem, I'm making this bug dependent on
resolution of bz 207598, so that we are left with a testable kdump package at
all times

Comment 3 Neil Horman 2006-09-29 16:57:49 UTC
Created attachment 137404 [details]
omnibus patch of viveks requested changes to go in when bz 207598 clears

Comment 4 Neil Horman 2006-10-17 15:27:07 UTC
accepted in -98.el5.  Thanks!

Comment 5 Jay Turner 2007-02-13 17:10:06 UTC
kexec-tools-1.101-164.el5 included in 20070208.0 trees.


Note You need to log in before you can comment on or make changes to this bug.