Bug 2082878 - Firefox crashes under wayland when dragged in dual head display with different scaling
Summary: Firefox crashes under wayland when dragged in dual head display with differen...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 36
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-05-08 05:43 UTC by trevor
Modified: 2022-05-30 05:57 UTC (History)
12 users (show)

Fixed In Version: firefox-100.0-4.fc36 firefox-100.0-4.fc35 firefox-100.0.2-2.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-12 01:13:02 UTC
Type: Bug


Attachments (Terms of Use)

Description trevor 2022-05-08 05:43:40 UTC
Description of problem:

Firefox crashes when dragged over (or near) the boundary of two displays in a dual display setup, where the displays are differently scaled.

Version-Release number of selected component (if applicable):
firefox-100.0-2.fc36

How reproducible:
Always afaict

Steps to Reproduce:
1. Have two displays with different scaling. I have a laptop with high resolution display scaled at 125% in Gnome settings and a 24" monitor scaled at 100%. With these settings the displays appear to be at a similar scale, i.e. the fonts appear about the same size on both displays 
2. Open Firefox on one display and browse to any page.
3. Drag Firefox with the mouse so that the window moves partially to the other display

Actual results:
Firefox immediately crashes

Expected results:
4. Firefox should not crash

This only appears to happen when using Wayland. If I start with firefox-x11, then Firefox does not crash. 
If both displays have the same scaling, i.e. 100%, then Firtefox does not crash.
I never saw this behaviour in Fedora 35.




Additional info:

Comment 1 James 2022-05-08 11:51:14 UTC
Observed here in Wayland GNOME with:

firefox-100.0-2.fc36.x86_64
mutter-42.0-6.fc36.x86_64
gnome-shell-42.0-3.fc36.x86_64

Comment 2 Tom Hughes 2022-05-09 07:47:51 UTC
I don't know if it's the same but I'm seeing a lot of crashes since upgrading to F36 on a system with a high resolution display scaled at 125% but mine seem to have been triggered either when I switch to a different workspace or when I switch user or wake the display from sleep - basically anything triggers a rerender of the screen.

It doesn't always happen when I do those things but it always seems to be one of those that triggers it.

Unfortunately I don't have a backtrace yet because firefox steals the crashes for Mozilla's crash reporter...

Comment 3 Martin Stransky 2022-05-09 10:24:13 UTC
Can you attach any of the crashes from Mozilla?
https://fedoraproject.org/wiki/How_to_debug_Firefox_problems#Collect_information_for_a_bug_report
Thanks.

Comment 4 Tom Hughes 2022-05-09 10:42:28 UTC
I think https://crash-stats.mozilla.org/report/index/7022d42d-d332-4b1d-9de0-b39220220508 is one of mine. Certainly it has a highly suspicious crash reason of:

wl_surface@97: error 2: Buffer size (1427x1036) must be an integer multiple of the buffer_scale (2)

Comment 5 Martin Stransky 2022-05-09 12:12:31 UTC
(In reply to Tom Hughes from comment #4)
> I think
> https://crash-stats.mozilla.org/report/index/7022d42d-d332-4b1d-9de0-
> b39220220508 is one of mine. Certainly it has a highly suspicious crash
> reason of:
> 
> wl_surface@97: error 2: Buffer size (1427x1036) must be an integer multiple
> of the buffer_scale (2)

That's https://bugzilla.mozilla.org/show_bug.cgi?id=1767916

Comment 6 Martin Stransky 2022-05-09 12:18:15 UTC
Added to firefox-100.0-4

Comment 7 trevor 2022-05-09 22:38:27 UTC
My bug report, https://crash-stats.mozilla.org/report/index/ab15e269-46f2-48da-aa2b-1cd1f0220509 has the same crash reason:

wl_surface@50: error 2: Buffer size (1426x1015) must be an integer multiple of the buffer_scale (2)

Comment 8 Fedora Update System 2022-05-10 17:55:51 UTC
FEDORA-2022-9434036d03 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2022-9434036d03

Comment 9 Fedora Update System 2022-05-10 17:55:53 UTC
FEDORA-2022-f75f41c5fa has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-f75f41c5fa

Comment 10 Fedora Update System 2022-05-10 17:55:55 UTC
FEDORA-2022-a7483d9478 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-a7483d9478

Comment 11 Fedora Update System 2022-05-11 02:38:06 UTC
FEDORA-2022-a7483d9478 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-a7483d9478`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-a7483d9478

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2022-05-11 02:45:33 UTC
FEDORA-2022-f75f41c5fa has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-f75f41c5fa`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-f75f41c5fa

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2022-05-11 03:17:04 UTC
FEDORA-2022-9434036d03 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-9434036d03`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-9434036d03

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 trevor 2022-05-11 06:52:37 UTC
Ran update as suggested above.  Works for me. No crashes evident when moving between differently scaled displays.

Comment 15 Fedora Update System 2022-05-12 01:13:02 UTC
FEDORA-2022-a7483d9478 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 16 Fedora Update System 2022-05-13 01:36:28 UTC
FEDORA-2022-f75f41c5fa has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 17 Fedora Update System 2022-05-24 02:05:20 UTC
FEDORA-2022-364d5beceb has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-364d5beceb`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-364d5beceb

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 18 Fedora Update System 2022-05-26 03:21:40 UTC
FEDORA-2022-c5a8d2c7f4 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-c5a8d2c7f4`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-c5a8d2c7f4

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Fedora Update System 2022-05-30 05:57:03 UTC
FEDORA-2022-c5a8d2c7f4 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.