Bug 208304 - lockdep annotation not right?
Summary: lockdep annotation not right?
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Peter Zijlstra
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FCMETA_LOCKDEP 209199
TreeView+ depends on / blocked
 
Reported: 2006-09-27 19:39 UTC by Gary Lindstrom
Modified: 2014-08-11 05:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-08 18:22:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gary Lindstrom 2006-09-27 19:39:06 UTC
Description of problem:

Get the following on bootup - most likely in the scsi driver for my compaq/hp
integrated raid controllers (both 5i and 6i on DL360/380 G2 and G4, maybe others):

Sep 24 18:29:20 spool6 kernel: INFO: trying to register non-static key.
Sep 24 18:29:20 spool6 kernel: the code is fine but needs lockdep annotation.
Sep 24 18:29:20 spool6 kernel: turning off the locking correctness validator.
Sep 24 18:29:20 spool6 kernel:  [<c04051ee>] show_trace_log_lvl+0x58/0x171
Sep 24 18:29:20 spool6 kernel:  [<c0405802>] show_trace+0xd/0x10
Sep 24 18:29:20 spool6 kernel:  [<c040591b>] dump_stack+0x19/0x1b
Sep 24 18:29:20 spool6 kernel:  [<c043b366>] __lock_acquire+0xfd/0x99c
Sep 24 18:29:20 spool6 kernel:  [<c043c176>] lock_acquire+0x4b/0x6d
Sep 24 18:29:20 spool6 kernel:  [<c06155a4>] _spin_lock_irq+0x1f/0x2e
Sep 24 18:29:20 spool6 kernel:  [<c0613422>] wait_for_completion+0x29/0x9e
Sep 24 18:29:20 spool6 kernel:  [<f88cfc36>] sendcmd_withirq+0x173/0x289 [cciss]
Sep 24 18:29:20 spool6 kernel:  [<f88d0c9a>] cciss_read_capacity+0x2f/0xa6 [cciss]
Sep 24 18:29:20 spool6 kernel:  [<f88d2c32>] cciss_revalidate+0xaa/0xfa [cciss]
Sep 24 18:29:20 spool6 kernel:  [<c04a8380>] rescan_partitions+0x6b/0x1e7
Sep 24 18:29:20 spool6 kernel:  [<c047a5c8>] do_open+0x2e9/0x3e9
Sep 24 18:29:20 spool6 kernel:  [<c047a739>] blkdev_get+0x71/0x7c
Sep 24 18:29:20 spool6 kernel:  [<c04a82c3>] register_disk+0x115/0x167
Sep 24 18:29:20 spool6 kernel:  [<c04e099b>] add_disk+0x2e/0x3d
Sep 24 18:29:20 spool6 kernel:  [<f88d356a>] cciss_init_one+0x8e8/0xa5a [cciss]
Sep 24 18:29:20 spool6 kernel:  [<c04f4241>] pci_device_probe+0x39/0x5b
Sep 24 18:29:20 spool6 kernel:  [<c05552d6>] driver_probe_device+0x45/0x92
Sep 24 18:29:20 spool6 kernel:  [<c0555403>] __driver_attach+0x68/0x93
Sep 24 18:29:20 spool6 kernel:  [<c0554d4f>] bus_for_each_dev+0x3a/0x5f
Sep 24 18:29:20 spool6 kernel:  [<c0555231>] driver_attach+0x14/0x17
Sep 24 18:29:20 spool6 kernel:  [<c0554a26>] bus_add_driver+0x68/0x106
Sep 24 18:29:20 spool6 kernel:  [<c05556ac>] driver_register+0x78/0x7d
Sep 24 18:29:20 spool6 kernel:  [<c04f4392>] __pci_register_driver+0x4f/0x69
Sep 24 18:29:20 spool6 kernel:  [<f880401c>] cciss_init+0x1c/0x1e [cciss]
Sep 24 18:29:21 spool6 kernel:  [<c04426ce>] sys_init_module+0x16ad/0x1856
Sep 24 18:29:21 spool6 kernel:  [<c0403faf>] syscall_call+0x7/0xb
Sep 24 18:29:21 spool6 kernel: DWARF2 unwinder stuck at syscall_call+0x7/0xb
Sep 24 18:29:21 spool6 kernel: Leftover inexact backtrace:
Sep 24 18:29:21 spool6 kernel:  [<c0405802>] show_trace+0xd/0x10
Sep 24 18:29:21 spool6 kernel:  [<c040591b>] dump_stack+0x19/0x1b
Sep 24 18:29:21 spool6 kernel:  [<c043b366>] __lock_acquire+0xfd/0x99c
Sep 24 18:29:21 spool6 kernel:  [<c043c176>] lock_acquire+0x4b/0x6d
Sep 24 18:29:21 spool6 kernel:  [<c06155a4>] _spin_lock_irq+0x1f/0x2e
Sep 24 18:29:21 spool6 kernel:  [<c0613422>] wait_for_completion+0x29/0x9e
Sep 24 18:29:21 spool6 kernel:  [<f88cfc36>] sendcmd_withirq+0x173/0x289 [cciss]
Sep 24 18:29:21 spool6 kernel:  [<f88d0c9a>] cciss_read_capacity+0x2f/0xa6 [cciss]
Sep 24 18:29:21 spool6 kernel:  [<f88d2c32>] cciss_revalidate+0xaa/0xfa [cciss]
Sep 24 18:29:21 spool6 kernel:  [<c04a8380>] rescan_partitions+0x6b/0x1e7
Sep 24 18:29:21 spool6 kernel:  [<c047a5c8>] do_open+0x2e9/0x3e9
Sep 24 18:29:21 spool6 kernel:  [<c047a739>] blkdev_get+0x71/0x7c
Sep 24 18:29:21 spool6 kernel:  [<c04a82c3>] register_disk+0x115/0x167
Sep 24 18:29:21 spool6 kernel:  [<c04e099b>] add_disk+0x2e/0x3d
Sep 24 18:29:21 spool6 kernel:  [<f88d356a>] cciss_init_one+0x8e8/0xa5a [cciss]
Sep 24 18:29:21 spool6 kernel:  [<c04f4241>] pci_device_probe+0x39/0x5b
Sep 24 18:29:21 spool6 kernel:  [<c05552d6>] driver_probe_device+0x45/0x92
Sep 24 18:29:21 spool6 kernel:  [<c0555403>] __driver_attach+0x68/0x93
Sep 24 18:29:21 spool6 kernel:  [<c0554d4f>] bus_for_each_dev+0x3a/0x5f
Sep 24 18:29:21 spool6 kernel:  [<c0555231>] driver_attach+0x14/0x17
Sep 24 18:29:21 spool6 kernel:  [<c0554a26>] bus_add_driver+0x68/0x106
Sep 24 18:29:21 spool6 kernel:  [<c05556ac>] driver_register+0x78/0x7d
Sep 24 18:29:21 spool6 kernel:  [<c04f4392>] __pci_register_driver+0x4f/0x69
Sep 24 18:29:21 spool6 kernel:  [<f880401c>] cciss_init+0x1c/0x1e [cciss]
Sep 24 18:29:21 spool6 kernel:  [<c04426ce>] sys_init_module+0x16ad/0x1856
Sep 24 18:29:21 spool6 kernel:  [<c0403faf>] syscall_call+0x7/0xb

Version-Release number of selected component (if applicable):

All kernels tested with FC6 Test - maybe others.

How reproducible:

Occurs every boot...

Steps to Reproduce:
1. Boot server

Comment 1 Don Zickus 2006-09-28 22:31:34 UTC
in kernel-2.6.18-1.2707.el5.bz208456

Comment 2 Dave Jones 2006-09-28 22:54:10 UTC
will be in tomorrows rawhide.


Comment 3 Gary Lindstrom 2006-10-03 20:41:16 UTC
Not sure which kernel it was put in, but it seems to be fixed in
2.6.18-1.2724.fc6, at least on the DL380 G4...  Thanks!

Comment 4 Gary Lindstrom 2006-10-03 22:28:06 UTC
Hmmm... I just found this on another of my machines...  I am thinking this is
the Emulex FC HBA as listed:

Oct  3 14:54:56 virtual1b kernel: Emulex LightPulse Fibre Channel SCSI driver 8.1.9
Oct  3 14:54:56 virtual1b kernel: Copyright(c) 2004-2006 Emulex.  All rights
reserved.

I don't seem to see this on the machines with the Qlogic FC HBA.  Do you need
anything more from me to fix this?  Here is the error:

Oct  3 15:56:06 virtual1b kernel: scsi1 :  on PCI bus 07 device 20 irq 15
Oct  3 15:56:06 virtual1b kernel: INFO: trying to register non-static key.
Oct  3 15:56:06 virtual1b kernel: the code is fine but needs lockdep annotation.
Oct  3 15:56:06 virtual1b kernel: turning off the locking correctness validator.
Oct  3 15:56:06 virtual1b kernel:  [<c04051ed>] show_trace_log_lvl+0x58/0x16a
Oct  3 15:56:06 virtual1b kernel:  [<c04057fa>] show_trace+0xd/0x10
Oct  3 15:56:06 virtual1b kernel:  [<c0405913>] dump_stack+0x19/0x1b
Oct  3 15:56:06 virtual1b kernel:  [<c043b1e2>] __lock_acquire+0xf0/0x90d
Oct  3 15:56:06 virtual1b kernel:  [<c043bf70>] lock_acquire+0x4b/0x6b
Oct  3 15:56:06 virtual1b kernel:  [<c061472f>] _spin_lock_irqsave+0x22/0x32
Oct  3 15:56:07 virtual1b kernel:  [<c04363d3>] prepare_to_wait+0x17/0x4b
Oct  3 15:56:07 virtual1b kernel:  [<f89a24b6>] lpfc_do_work+0xdd/0xcc2 [lpfc]
Oct  3 15:56:07 virtual1b kernel:  [<c04361b9>] kthread+0xc3/0xf2
Oct  3 15:56:07 virtual1b kernel:  [<c0402005>] kernel_thread_helper+0x5/0xb
Oct  3 15:56:07 virtual1b kernel: DWARF2 unwinder stuck at
kernel_thread_helper+0x5/0xb
Oct  3 15:56:07 virtual1b kernel: Leftover inexact backtrace:
Oct  3 15:56:07 virtual1b kernel:  [<c04057fa>] show_trace+0xd/0x10
Oct  3 15:56:07 virtual1b kernel:  [<c0405913>] dump_stack+0x19/0x1b
Oct  3 15:56:07 virtual1b kernel:  [<c043b1e2>] __lock_acquire+0xf0/0x90d
Oct  3 15:56:07 virtual1b kernel:  [<c043bf70>] lock_acquire+0x4b/0x6b
Oct  3 15:56:07 virtual1b kernel:  [<c061472f>] _spin_lock_irqsave+0x22/0x32
Oct  3 15:56:07 virtual1b kernel:  [<c04363d3>] prepare_to_wait+0x17/0x4b
Oct  3 15:56:07 virtual1b kernel:  [<f89a24b6>] lpfc_do_work+0xdd/0xcc2 [lpfc]
Oct  3 15:56:07 virtual1b kernel:  [<c04361b9>] kthread+0xc3/0xf2
Oct  3 15:56:07 virtual1b kernel:  [<c0402005>] kernel_thread_helper+0x5/0xb


Comment 5 Dave Jones 2006-10-28 05:42:59 UTC
That's a new problem.  Peter ?


Comment 6 Peter Zijlstra 2006-11-06 10:41:01 UTC
Yeah it was:
 http://lkml.org/lkml/2006/10/28/75

Comment 7 Dave Jones 2006-11-08 18:22:18 UTC
ok, devel/ is rebased to .19rc5 which includes this, so I'll close this out.
FC6 has lockdep off, so this doesn't matter there.

I'll start doing rawhide builds again soon.


Note You need to log in before you can comment on or make changes to this bug.