Bug 2083110 - Error usr/bin/icecat: line 72: fg: no job control when starting icecat from a terminal
Summary: Error usr/bin/icecat: line 72: fg: no job control when starting icecat from a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: icecat
Version: 36
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Antonio T. sagitter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-05-09 10:19 UTC by grumpey0
Modified: 2022-05-20 01:24 UTC (History)
2 users (show)

Fixed In Version: icecat-91.9.0-2.rh1.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-20 01:24:54 UTC
Type: Bug


Attachments (Terms of Use)

Description grumpey0 2022-05-09 10:19:42 UTC
Description of problem:
When starting icecat on a terminal receive an error: /usr/bin/icecat: line 72: fg: no job control

Version-Release number of selected component (if applicable):
GNU IceCat 91.9.0esr

How reproducible:
Open Terminal, type icecat and enter

Steps to Reproduce:
1. Open Terminal
2. Type icecat
3. Hit Enter

Actual results:
Receive Error usr/bin/icecat: line 72: fg: no job control

Expected results:
No Errors

Additional info:
In /usr/bin/icecat, line 72: 
if %{wayland_default} && ! [ $MOZ_DISABLE_WAYLAND ]; then

In the spec file, this looks like it may be the issue. 
line 669 in the spec file 
%{__sed} -e 's/__DEFAULT_WAYLAND__/%{wayland_default}/' \

sed -e 's/__DEFAULT_WAYLAND__/\[ \$WAYLAND_DISPLAY \]/' works on the command line.

Bug was pointed out here: https://ask.fedoraproject.org/t/fedora-35-and-icecat-browser/22060/2

Comment 1 Fedora Update System 2022-05-10 15:04:42 UTC
FEDORA-2022-2090d24863 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-2090d24863

Comment 2 Fedora Update System 2022-05-11 02:45:27 UTC
FEDORA-2022-2090d24863 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-2090d24863`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-2090d24863

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2022-05-11 09:22:16 UTC
FEDORA-2022-4b31163857 has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-4b31163857

Comment 4 Fedora Update System 2022-05-12 03:07:15 UTC
FEDORA-2022-4b31163857 has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-4b31163857`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-4b31163857

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2022-05-19 01:22:42 UTC
FEDORA-2022-2090d24863 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 Fedora Update System 2022-05-20 01:24:54 UTC
FEDORA-2022-4b31163857 has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.