Bug 208325 - Invalid checksums from ftp transfer of ISOs.
Invalid checksums from ftp transfer of ISOs.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ftp (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Marcela Mašláňová
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-27 17:16 EDT by Michael DeGon
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 21:22:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael DeGon 2006-09-27 17:16:12 EDT
Description of problem:
Running the the ftp test  downloading ISO from ftp mirrors. Comparing the
SHA1SUM file to the md5sum output of the downloaded ISO with an invalid result.
The byte size  matches between source and target files, but the checksum does not. 

Version-Release number of selected component (if applicable):
FC6T3

How reproducible:
  

Steps to Reproduce:
1.Use command ftp client to download an ISO image from any of the Fedora mirror
servers.
2.Also download the present SHA1SUM file.
3.Compare md5sum output with the SHA1SUM file.

  
Actual results:
ISO file byte target and source size matches, but the md5sum output and SHA1SUM
do not. 

Expected results:
the md5sum output and stated md5sum SHA1SUM file entry match.

Additional info:
This problem has been found on 5 intel PC models with different network card
chipsets. This looks like at FC6T3 specific problem. They are:

Model #             LAN Component
D946GZTSSL          82562G (EkronC) 
D915GAGLK  	    Marvell Yukon 88E8050 (1K)
D945GNTLKR  	    Intel 82573V (1K)  	 
D101GGC  	    Realtek* 8101L  
D101GGC  	    Realtek* 8101L
Comment 1 Juha Leppänen 2006-09-28 18:07:47 EDT
Hi,

Did you compare md5sum output to a corresponding item in file SHA1SUM?
md5sum checksums do not match sha1sum checksums.
You should compare sha1sum output, not md5sum output, to a corresponding item in
file SHA1SUM.

Juha
Comment 2 Michael DeGon 2006-09-28 21:22:28 EDT
Ah! 

I achieved my goal of learnig something new today!! 

You are right, the md5sum is different than the SHA1SUM. 

Please forgive my phoepa!
Comment 3 Juha Leppänen 2006-09-29 03:39:15 EDT
De nada. Glad to be able to help.

Note You need to log in before you can comment on or make changes to this bug.