RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 2083274 - Specifying the openssl config file explicitly causes provider initialisation to fail in FIPS mode
Summary: Specifying the openssl config file explicitly causes provider initialisation ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 9
Classification: Red Hat
Component: openssl
Version: 9.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Dmitry Belyavskiy
QA Contact: Hubert Kario
URL:
Whiteboard:
: 2085401 (view as bug list)
Depends On:
Blocks: 2085500
TreeView+ depends on / blocked
 
Reported: 2022-05-09 15:21 UTC by Hubert Kario
Modified: 2023-06-05 15:56 UTC (History)
4 users (show)

Fixed In Version: openssl-3.0.1-29.el9
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 2085500 (view as bug list)
Environment:
Last Closed: 2023-06-05 15:56:12 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker CRYPTO-7210 0 None None None 2022-05-11 12:35:10 UTC
Red Hat Issue Tracker RHELPLAN-121459 0 None None None 2022-05-09 15:33:14 UTC

Description Hubert Kario 2022-05-09 15:21:43 UTC
Description of problem:
When openssl is used with explicitly specified config file in FIPS mode, the provider loading fails

Version-Release number of selected component (if applicable):
openssl-3.0.1-27.el9

How reproducible:
always

Steps to Reproduce:
1. openssl genpkey -algorithm rsa -out cakey.pem
2. openssl req -config /etc/pki/tls/openssl.cnf -passout pass:securepass -new -x509 -days 3650 -extensions v3_ca -keyout cakey.pem -out cacert.pem             -subj "/C=XX/ST=mystate/L=mytown/O=myorganisation/OU=myou/CN=myname/emailAddress=myemail/"

Actual results:
005C9966037F0000:error:0700006D:configuration file routines:module_run:module initialization error:crypto/conf/conf_mod.c:243:module=providers, value=provider_sect retcode=-1

Expected results:
CSR created

Additional info:

Comment 4 Dmitry Belyavskiy 2022-05-13 14:10:10 UTC
*** Bug 2085401 has been marked as a duplicate of this bug. ***

Comment 7 Clemens Lang 2023-06-05 15:56:12 UTC
RHEL 9.1 contains openssl-3.0.1-43.el9_0.


Note You need to log in before you can comment on or make changes to this bug.