Bug 208332 - [RHEL5 Beta1] mkinitrd: system panic during boot time in multipath root environment.
[RHEL5 Beta1] mkinitrd: system panic during boot time in multipath root envir...
Status: CLOSED DUPLICATE of bug 157082
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-27 17:46 EDT by Kiyoshi Ueda
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-27 17:50:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kiyoshi Ueda 2006-09-27 17:46:05 EDT
Description of problem:
System panic often occurs during boot time, when the root filesystem
is on a multipath device and the multipath storage has many LUNs.

When a storage has many LUNs and multiple ports which are connected
to QLogic FC cards, the device name of each LUN varies in each reboot
in the current RHEL5, since QLogic FC cards are initialized almost
in parallel.

On the other hand, mkinitrd assumes the device name (actually major
and minor number) is same.
So wrong multipath maps can be created during boot time on initrd
environment, and the root filesystem can't be found.


Version-Release number of selected component:
mkinitrd-5.1.15-1


How reproducible:
Often in 4 LUNs and 2 ports environment.
(Failed 9 times while 10 trials.)


Steps to Reproduce:
 0. Prepare a multipath storage which has many LUNs and
    some QLogic FC cards.
 1. Connect those cards and ports of the storage to create
    multipath environment.
 2. Install OS to the multipath storage by using multipath root
    support of the installer.
    (Boot filesystem (like /boot or /boot/efi) doesn't need to install
     to a multipath device.)
 3. Boot the installed OS.


Actual results:
Can't find the root filesystem and system panic occurs.
-------------------------------------------------------------------
Loading dm-multipath.ko module
device-mapper: multipath: version 1.0.4 loaded
Loading dm-round-robin.ko module
device-mapper: multipath round-robin: version 1.0.0 loaded
Creating root device.
Mounting root filesystem.
mount: could not find filesystem '/dev/root'
Setting up other fKernel panic - not syncing: Attempted to kill init!
-------------------------------------------------------------------


Expected results:
System panic should not occur.


Additional info:
Comment 1 Peter Jones 2006-09-27 17:50:53 EDT

*** This bug has been marked as a duplicate of 157082 ***

Note You need to log in before you can comment on or make changes to this bug.