Bug 2083378 - storage role cannot set mount_options for volumes
Summary: storage role cannot set mount_options for volumes
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: rhel-system-roles
Version: 8.7
Hardware: Unspecified
OS: Unspecified
Target Milestone: rc
: 8.7
Assignee: Rich Megginson
QA Contact: Zhang Yi
Michal Stubna
Whiteboard: role:storage
Depends On: 2083376
Blocks: 2098227
TreeView+ depends on / blocked
Reported: 2022-05-09 20:17 UTC by Rich Megginson
Modified: 2022-11-08 10:37 UTC (History)
8 users (show)

Fixed In Version: rhel-system-roles-1.18.0-1.el8
Doc Type: Bug Fix
Doc Text:
.The `mount_options` parameter for volumes is now valid for a volume Previously, the parameter was accidentally removed from the list of valid parameters for a volume. Consequently, users were unable to set the `mount_options` parameter for volumes. With this bug fix, the `mount_options` parameter has been added back to the list of valid parameters and the code has been refactored to catch the errors. As a result, the `storage` RHEL system role can set the `mount_options` parameter for volumes.
Clone Of: 2083376
: 2098227 (view as bug list)
Last Closed: 2022-11-08 09:41:24 UTC
Type: Bug
Target Upstream Version:
pkettman: needinfo+

Attachments (Terms of Use)

System ID Private Priority Status Summary Last Updated
Github linux-system-roles storage pull 270 0 None open add support for mount_options 2022-05-09 20:47:45 UTC
Red Hat Issue Tracker RHELPLAN-121487 0 None None None 2022-10-10 13:09:55 UTC
Red Hat Product Errata RHEA-2022:7568 0 None None None 2022-11-08 09:41:55 UTC

Description Rich Megginson 2022-05-09 20:17:37 UTC
+++ This bug was initially created as a clone of Bug #2083376 +++

Description of problem:

The "mount_options" parameter of "storage_volumes" does not work.  The parameter is documented here: https://github.com/linux-system-roles/storage#mount_options

I modified one of the existing tests to add

            mount_options: rw,noatime,defaults

For the controller, I'm using f35 with ansible-core 2.12, latest storage git repo.  For the managed host, I have tried rhel 8.5, rhel 8.6, and fedora 34.  They all give the same error:

'Unsupported parameters for (blivet) module: volumes.mount_options. Supported parameters include: volume_defaults, packages_only, disklabel_type, volumes, diskvolume_mkfs_option_map, pools, use_partitions, pool_defaults, safe_mode.'

This problem was introduced in this commit: https://github.com/linux-system-roles/storage/commit/c3b81cb8b44b587cbc9b0f274b08ebf483bbd0a8

Version-Release number of selected component (if applicable):

RHEL 8.6/RHEL 9.0

`mount_options` is supported in RHEL 8.5

How reproducible:

Steps to Reproduce:

Actual results:

Expected results:

Additional info:

Comment 10 errata-xmlrpc 2022-11-08 09:41:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (rhel-system-roles bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.