Bug 20834 - Executables will not execute!
Executables will not execute!
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-14 11:44 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-14 11:44:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-14 11:44:03 EST
After installing RedHat Linux 7, I began to have a very weird, and quite
detrimental problem...

Matlab 5.3 will not execute.  On running the executables I recieve all
kinds of "command not found" messages despite the fact that the file
exists.

In addition, I'm having the same problem with the Laey package of Fortran
90 compilers.

I read your previous message about libc5... however these packages run fine
under RedHat 6.2 - which as far as I was aware, do not run libc5.

As this seems to be a fairly widespread problem affecting all sorts of
software your general user may wish to install under RedHat 7 - it seems
like you ought to produce a document outlining how to fix this.

May I point out that these are the latest releases of this software.  And
it stands to reason that the new release of Linux ought to support the
newest releases of various software packages, or what's the point of
upgrading.

Let me know if you can help, otherwise I'll be unhappily downgrading to an
earlier version of linux.
Comment 1 Bernhard Rosenkraenzer 2000-11-14 11:53:48 EST
It is a libc5 issue.
Red Hat Linux 6.x used glibc (libc6) by default, but had a compatibility package for old libc5 applications. We've kept a compatibility library for an obsolete and broken libc for about 2 years - that should be enough time for any serious software vendor to update.

If you need to use libc5 applications on Red Hat Linux 7, install the libc and ld.so packages from Red Hat Linux 6.x - they'll work, and provide the same backwards compatibility 6.x had.

Note You need to log in before you can comment on or make changes to this bug.