Bug 208345 - Hundreds of zombies on my system
Hundreds of zombies on my system
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
http://xcski.com/munin/xcski.com/allh...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-27 18:22 EDT by ptomblin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-30 03:23:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ps auwwfx (66.95 KB, text/plain)
2006-09-27 18:22 EDT, ptomblin
no flags Details

  None (edit)
Description ptomblin 2006-09-27 18:22:21 EDT
Description of problem:
Since yum installed glibc 2.4-11 on the 16th of this month, my system has been
accumulating zombies at a horrific rate.

Version-Release number of selected component (if applicable):
glibc-2.4-11

How reproducible:
Very

Steps to Reproduce:
1. Use the system
2. Note the number of processes creeping up at a fairly fast clip.
3.
  
Actual results:
Over 700 processes on my system, and increasing at a constant rate.

Expected results:
Approximately 200-250 processes on my system at any given time.

Additional info:
See the above munin graph showing the number of processes increasing.

I'm attaching the results of a "ps auwwfx".
Comment 1 ptomblin 2006-09-27 18:22:21 EDT
Created attachment 137260 [details]
ps auwwfx
Comment 2 ptomblin 2006-09-27 20:33:36 EDT
An additional symptom: when I try to shutdown, I get the following:

shutdown: timeout opening/writing control channel /dev/initctl

init: timeout opening/writing control channel /dev/initctl

I had to hit the reset button to reboot.
Comment 3 ptomblin 2006-09-28 07:00:40 EDT
Rebooting appears to have fixed the problem.  It appears that upgrading
something, probably glibc, without rebooting was the cause.
Comment 4 Jakub Jelinek 2006-09-30 03:23:48 EDT
Couldn't reproduce this on any of the 6 boxes I have upgraded FC5 glibc to.
If anything, it would be a kernel issue.

Note You need to log in before you can comment on or make changes to this bug.