Bug 208368 - pre-editing state problem on Hangul with click action in oowriter
pre-editing state problem on Hangul with click action in oowriter
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openoffice.org (Show other bugs)
4.4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-28 01:12 EDT by Jong Bae KO
Modified: 2007-11-16 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 04:35:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jong Bae KO 2006-09-28 01:12:49 EDT
Description of problem:
If you click(mouse action) in pre-editing state in a oowriter, the letter from
pre-editing will be disappeared in the oowriter.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.5-4.6.0.EL4
iiimf-hangul-12.1-13.EL.5


How reproducible:
allways

Steps to Reproduce:
1. run oowriter with IIIMF
2. activate Hangul
3. type "gks"
4. click the mouse on empty space
  
Actual results:
Null

Expected results:
한


Additional info:
Comment 1 Caolan McNamara 2006-09-28 04:14:47 EDT
This is a bug reported against RHEL-4 1.1.5. So it will probably never die :-(
because in practise there is just not going to be any updates which fix
behaviour in areas like the IM for the 1.1.X series. Reporting non-crash
problems against the 1.1.X series is fairly futile I'm afraid.

Taking the 2.0.X series if you type gks and leave it uncommitted and click the
mouse about the page, then the character will follow the mouse around until you
commit it. 
Comment 2 Jong Bae KO 2006-09-28 04:29:40 EDT
Yes, 2.0.X series work fine in FC6. 
Comment 3 Leon Ho 2006-09-28 04:35:48 EDT
I think it shouldn't commit anything automatically, but I agree the behavior in
OOo1 is not ideal but it is not too bad. The acceptable behavior will what we
have in gedit and OOo2, preedit will follow cursor. I agree with Caolan, I
suggest to close this as WONTFIX for RHEL4.

Note You need to log in before you can comment on or make changes to this bug.