Bug 208386 - GNOME screwed after upgrade
GNOME screwed after upgrade
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: GConf2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-09-28 06:32 EDT by David Woodhouse
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-06 14:09:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2006-09-28 06:32:38 EDT
After upgrading a system from FC5 to rawhide, GNOME was mostly non-functional.
New users got a black background and an _empty_ panel, with messages in
.xsession-errors from gnome-panel, suggesting that 'gconftool-2 --load' has not
been run. Running gnome-theme-manager failed, suggesting that metacity isn't
installed (which it was, of course) or that gconf was misconfigured.

Removing the contents of /etc/gconf/gconf.xml.defaults and replacing the entire
directory with the contents of same from a newly-installed rawhide machine was
sufficient to fix this.

But these files don't seem to be owned by any package, and I can't see how they
get created.
Comment 1 David Woodhouse 2006-09-28 11:14:18 EDT
Found this in /root/upgrade.log...

Upgrading system-config-display - 1.0.45-1.noarch
/var/tmp/rpm-tmp.30456: line 2: [-x: command not found
Must set the GCONF_CONFIG_SOURCE environment variable
error: %postun(gconf-editor-2.10.0-2.ppc) scriptlet failed, exit status 1
Cache file created successfully.
Must set the GCONF_CONFIG_SOURCE environment variable
error: %postun(gconf-editor-2.10.0-3.ppc) scriptlet failed, exit status 1
warning: /etc/alchemist/namespace/printconf/local.adl saved as
/etc/alchemist/namespace/printconf/local.adl.rpmsave
warning: /etc/sysconfig/rhn/sources saved as /etc/sysconfig/rhn/sources.rpmsave
Comment 2 Ray Strode [halfline] 2006-09-28 14:53:03 EDT
Looks like this bug 152238.
Comment 3 David Woodhouse 2006-09-28 15:42:21 EDT
Would that explain the whole thing? Or does bug 152238 only explain what I see
in comment 1 and not the original bug?
Comment 4 Ray Strode [halfline] 2007-03-06 14:09:07 EST
there was a problem a while back where gconftool-2 was segfaulting randomly.  I
think that would explain this behavior.

The bug was a kernel bug, but I can't seem to find it right now.

I'm going to close this bug because i'm trying to sweep up bugzilla today.  If
this is something you've hit again, please reopen the report, because it sounds
pretty serious.

Note You need to log in before you can comment on or make changes to this bug.