This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 208423 - traceback in anaconda get_table
traceback in anaconda get_table
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Mike McLean
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-09-28 10:38 EDT by Brian Brock
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-20 10:38:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brian Brock 2006-09-28 10:38:30 EDT
Anaconda tracebacks on at least i386 during attempted installation.

rawhide-20060928 tree
same traceback occurs with each install attempt



Traceback (most recent call last):
  File "/usr/bin/anaconda.py", line 905, in ?
    instClass.setInstallData(anaconda)
  File "/usr/lib/anaconda/kickstart.py", line 781, in setInstallData
    ds.startMPath()
  File "/usr/lib/anaconda/partedUtils.py", line 579, in startMPath
    mpList = dmraid.startAllMPath(driveList)
  File "/usr/lib/anaconda/partedUtils.py", line 229, in scanForMPath
    mpaths = block.getMPaths(probeDrives)
  File "/usr/lib/python-2.4/site-packages/block/__init__.py", line 91, in getMPaths
    mpList.append(apply(MultiPath, v, {}))
  File "/usr/lib/python-2.4/site-packages/block/device.py", line 221, in __init__
    table = self.get_table()
  File "/usr/lib/python-2.4/site-packages/block/device.py", line 360, in get_table
    table = apply(_dm.table, tableParts, {})
valueError: size must be positive
install exited abnormally [1/1]


ks.cfg looks like:
install
#cmdline
nfs --server=$SERVER --dir=$DIR
lang en_US.UTF-8
langsupport --default=en_US.UTF-8 en_US.UTF-8
keyboard us
network --device eth0 --bootproto dhcp
rootpw --iscrypted $CRYPTEDPASSWD
firewall --disabled
authconfig --enableshadow --enablemd5
selinux --enforcing
timezone America/New_York
bootloader --location=mbr --driveorder=sda --append="rhgb quiet"
reboot
# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
clearpart --all --initlabel
part /boot --fstype ext3 --size=100
part pv.2 --size=0 --grow
volgroup VolGroup00 --pesize=32768 pv.2
logvol / --fstype ext3 --name=LogVol00 --vgname=VolGroup00 --size=1023 --grow
logvol swap --fstype swap --name=LogVol01 --vgname=VolGroup00 --size=400 --grow
--maxsize=800

%packages --resolvedeps
@core
@base
Comment 1 Jeremy Katz 2006-09-28 10:56:17 EDT
Can you try adding 'nompath' to your boot options?  

Peter -- this stuff has _GOT_ to be fixed.  Even if it's by us catching the
exception and then just disabling mpath/dmraid.
Comment 2 Brian Brock 2006-09-28 15:00:26 EDT
Adding 'nompath' fixes the initial traceback.
Comment 3 Peter Jones 2006-09-29 14:16:01 EDT
Should be fixed with python-pyblock-0.24-1 and anaconda-11.1.0.103-1 .
Comment 4 Brian Brock 2007-03-20 10:38:05 EDT
I haven't seen this problem recently, closing.

Note You need to log in before you can comment on or make changes to this bug.