Bug 208461 - Include bttv and cx88 driver modules in kernel
Include bttv and cx88 driver modules in kernel
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: RHEL Product and Program Management
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-28 14:40 EDT by Ti Leggett
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version: 4.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-17 16:59:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ti Leggett 2006-09-28 14:40:11 EDT
Description of problem:
I'd like to request that the bttv and cx88 drivers be included in the standard RH kernel. And even better, 
I'd like to request a binary package (not a SRPM) of the fully patched and configured (i.e., includes 
a .config) kernel source. That way users could easily make RPMs of additional kernel modules they'd 
like that aren't included in the standard RHEL kernel.

Version-Release number of selected component (if applicable):
All RHEL 4

How reproducible:
N/A

Steps to Reproduce:
1. N/A
  
Actual results:
N/A

Expected results:
N/A

Additional info:
Comment 1 Jarod Wilson 2006-11-30 10:24:53 EST
The kernel-devel pacakges provide enough for the bulk of kernel modules to build
- - at least the sane ones. For anything that needs a full kernel tree for some
reason, you're just an rpmbuild -bp away from a fully patched and configured
source tree. Those parts we aren't likely to change. I doubt we'll turn on bttv
or cx88 for the RHEL4 kernel, but possibly for RHEL5 (in the current beta
kernel, bttv is currently enabled, but cx88 is not).
Comment 2 Jarod Wilson 2006-11-30 11:35:18 EST
I stand corrected, seems we're actually evaluating turning on some video capture
bits for the next RHEL4 update as well.

Personally, I'm hoping we turn on dvb as well for RHEL5, because then RHEL5
would make an excellent platform for a certain linux-based open-source PVR I use
at home... :)
Comment 4 Linda Wang 2006-12-01 09:44:32 EST
For now, please use FC as your base platform if dvb is on in that release.
Comment 5 Aristeu Rozanski 2007-08-17 16:59:39 EDT
cx88 and bttv are enabled in 4.6

Note You need to log in before you can comment on or make changes to this bug.