Bug 208506 - exo dependencies issues
exo dependencies issues
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: exo (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-28 17:29 EDT by Patrice Dumas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-06 13:52:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2006-09-28 17:29:16 EDT
Description of problem:

Here are some remarks about the exo package

* libxfcegui4-devel and libxfcegui are Requires and BR, 
  although nothing links against that lib.

* exo has a dependency on perl, because of exo-compose-mail-0.3.
  I think it is unfortunate. I don't know how to avoid that
  simply. Indeed it is used for almost all of the mail helpers
  which are in turn needed by exo-helper, and I guess exo-helper
  is used by other apps.

* exo-devel includes a python module. It should certainly be
  much better in a python-exo subpackage. And the .a and .la
  should be removed from the python directory.

* the mcs plugin isn't shipped. Is it intentional? To build it
  a BR xfce-mcs-manager-devel is required.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kevin Fenzi 2006-09-28 22:07:33 EDT
Thanks for the remarks. 

- Removed libxfcegui4-devel and libxfcegui Requires and BR

- I don't know of any way to avoid perl. I fear it's just going to have to be 
in there. ;( 

- I have split out a python-exo package. In the older exo the python bindings 
were not very usefull, but I think they have gotten some improvements lately. 

- Added BR xfce-mcs-manager-devel to ship the mcs plugin. 

Should be in the next exo release for my beta repo. If that looks good after a 
bit, I will push it out to devel. 
Comment 2 Kevin Fenzi 2006-10-06 13:52:12 EDT
This should be pushed out to devel now, and should be available after the next 
push of packages. 

I had to also add libxfce4util-devel to requires on the devel package, because 
the exo pc file requires it. 

I am going to close this bug now, but if you spot anything with the updated 
package feel free to file a new bug or reopen this one. 

Note You need to log in before you can comment on or make changes to this bug.