Bug 208510 - kdetoys: kweather isn't configurable
kdetoys: kweather isn't configurable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdetoys (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-28 18:18 EDT by Radek Bíba
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-13 08:38:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 122850 None None None Never

  None (edit)
Description Radek Bíba 2006-09-28 18:18:20 EDT
Description of problem:
Although I select any country and city in KDE Weather applet, it complains
that the station doesn't exist.

Version-Release number of selected component (if applicable):
kdetoys-3.5.3-3.fc5

How reproducible:
Always (tried on two FC5 boxes)

Steps to Reproduce:
1. app weather applet to the panel
2. configure any coutry/city
  
Actual results:
It just doesn't work

Expected results:
It should work :) I remember it worked in one of the old versions where
station codes were entered manually.

Additional info:
FYI, ~/.kde/share/config/weather_panelappletrc contains:
...
report_location=0000
...
and 0000 is also displayed in the menu header when you right-click on the
applet icon
Comment 1 Rex Dieter 2006-10-23 09:51:28 EDT
Thanks for the report.  

Unfortunately, I'm unable to duplicate the problem you report.  I *did* notice
that some stations took 30-60(+?) seconds to update properly (and before it did,
I received an "unknown station" error/warning).
Comment 2 Radek Bíba 2006-10-23 10:55:23 EDT
Hmm, in order to re-test it I stopped the applet, removed KWeatherServicerc and
weather_panelappletrc and started it again. The icon with question mark is in the
panel again and kweather can't be configured (nothing changes). As opposite to
fresh kweather start, weather_panelappletrc reads 'report_location=' and clicking
the panel icon, a window is displayed with Unknown station, and update time Feb
27 2935093 20:00 - wow!

After manually setting report_location to the desired code (by editing the file)
and restarting kweather, it's all working again.
Comment 3 Rex Dieter 2006-10-23 10:58:57 EDT
Creepy.  Do you have firewall enabled?  If so, could you try temporarily
disabling it while trying to configure kweather?  (I'm not sure how it pulls in
it's data, I had previously thought via http, but now I'm not so sure).
Comment 4 Radek Bíba 2006-11-01 22:40:33 EST
No luck with firewall disabled. I've even tried to set up kweather under a brand
new user, without any previous config files (which could matter) but the icon with
exclamation mark is still being displayed. And weather_panelappletrc contains
empty 'report_location=' (not sure why it was once set to 0000, as I said in
comment 0), while KWeatherServicerc has the right record in 'stations='.
Comment 5 Adam Bentitou 2007-04-13 01:26:36 EDT
I just hit the same problem in FC6.
However, I noticed there is now an upstream patch:
http://bugs.kde.org/show_bug.cgi?id=122850

I rebuilt my kdetoys with the above patch, and
it seems to work fine now.
Comment 6 Rex Dieter 2007-04-13 07:47:24 EDT
Thanks Adam!
Comment 7 Rex Dieter 2007-04-13 08:28:55 EDT
Arg, fix was in kde-3.5.6, and I simply forgot to update the package, my bad. 
Update coming shortly.
Comment 8 Rex Dieter 2007-04-13 08:38:34 EDT
%changelog
* Fri Apr 13 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 7:3.5.6-2
- Requires: kdebase (for directory ownership)

* Tue Jan 16 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 7:3.5.6-1
- kweather isn't configurable (#208510, kde#122850)
- kde-3.5.6
Comment 9 Radek Bíba 2007-04-15 05:28:55 EDT
Thanks, the updated package works great!

Note You need to log in before you can comment on or make changes to this bug.