This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 208515 - Too small mozilla fonts used in fedora release notes 5 and 6 for "class code".
Too small mozilla fonts used in fedora release notes 5 and 6 for "class code".
Status: CLOSED NOTABUG
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Release Notes Tracker
Karsten Wade
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-28 20:07 EDT by Reiner Wilhelms
Modified: 2007-04-18 13:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-10 12:49:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Reiner Wilhelms 2006-09-28 20:07:21 EDT
Description of problem:

In the release notes for Fedora 5, some very small fonts are used
and it's very hard to read: It is the font used for class code. 
For example, in the html one finds this:

... These build on the <code class="code">yum</code> utility ...

or this:

... a new package manager that replaces <code
class="code">system-config-packages</code>. 

The resulting font used for the words yum and system-config-packages
is extremely small compared to the rest of the text. 
Also the new release notes for Fedora core 6 look like this. 
It would be nice if this could be fixed. Thanks. 

Version-Release number of selected component (if applicable): 5.0


How reproducible: found same problem on a PC and a laptop with FC5


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jesse Keating 2006-09-28 20:13:04 EDT
Since we're about to release FC6, can you check the latest test release or
rawhide for this?
Comment 2 Reiner Wilhelms 2006-09-28 21:47:20 EDT
The same tiny fonts are still used in the most recent document 
for Fedora Core 6 Test 2:

http://fedora.redhat.com/docs/release-notes/fc6test2/

(The problem is that this is what by default every new user
of Fedora gets to read as release notes, and it diminishes the
quality somewhat)
Comment 3 Karsten Wade 2006-12-15 15:47:30 EST
We probably inherited this setting, and it certainly can be tweaked.  Sorry that
we didn't get this in our queue to fix for FC6, but we can look into fixing it
for an update of the package.  This would mean the changes would make it into an
ISO respin, and into the page for anyone who does a yum update.

I'm adding a couple of our CSS maintainers to the Cc: so this shows up more
prominently in their queue.
Comment 4 Paul W. Frields 2006-12-15 15:55:33 EST
I think this may be a websites problem, not Docs.  The CSS on the f.r.c web site
isn't under our control, IIRC -- it's set by the PHP on the site.  However, once
this stuff is migrated this bug may become obsolete.
Comment 5 Karsten Wade 2006-12-15 16:27:00 EST
Sorry, I wasn't reading carefully.

Reiner -- do you see this problem only on fedora.redhat.com, or also from the
file in /usr/share/doc/HTML/index.html?

If it is only fedora.redhat.com, I think I have the perms to fix that.
Comment 6 Reiner Wilhelms 2006-12-15 18:03:03 EST
I think Paul (post #4) is probably right that it's not
a bug in the documentation as such but in the headers
that determine what fonts are used for what part of the 
documents.

Carsten: I see the problem on both the local /usr/share/doc/HTML/index.html 
and for example in 
http://fedora.redhat.com/docs/release-notes/fc6/en_US/.

Whenever something (e.g., a command line to call yum)
is supposed to appear in a small light grey box, the text 
within the box is enormously tiny and one has to increase
the font size to be able to read it. Fedora documentation
is basically the only time I need to increase font size,
hardly ever necessary for any other online documents. 

It is not a bug, but a matter of good visual 
style in the online documentation: It appears to be 
no problem for people with very good vision, but would
be nice if it could be fixed in the future 
so it's easier to read the documentation.
Comment 7 Dimitris Glezos 2006-12-15 19:22:20 EST
This is not an actual "bug" of our CSS; it is a choice of the user's browser.

In particular, most browsers (including Firefox) render monospace fonts smaller.
Firefox has by default a 12pt font size selected for monospace fonts and a 16pt
for sans/serif. If one chooses 16pt for both, then the CSS is rendered
correctly. IE does the same, Konqueror gets it "correctly".

(If you remove completely the CSS, you will see that the browser still renders
the monospace font smaller than the normal one).

If we decide to override the default rendering, it can be done in our CSS like this:

  code, code.screen, pre.screen { font-size: 1.2em; }

This is a choice that should be left for the user though.
Comment 8 Karsten Wade 2007-02-10 12:49:32 EST
We discussed pushing this upstream as an RFE, but decided against that.  You can
feel free to do that directly yourself, via mozilla.org's bug report interface.

We are assuming that there is a good reason that Firefox has these settings;
they are derived from years of browser building.  As usual, one can always
override with local preferences, especially when people such as ourselves do not
munge the defaults ... if we did that, people who chose to blow up the monotype
font would suddenly have huge letters in their page.

Note You need to log in before you can comment on or make changes to this bug.