Bug 208518 - cal highlight has no commandline option
cal highlight has no commandline option
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-28 23:04 EDT by JW
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 04:06:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JW 2006-09-28 23:04:20 EDT
Description of problem:
There is no way to control 'cal' highlight of current date from command-line. It
is possible but requires reading of source code to figure out a way. 

Version-Release number of selected component (if applicable):
util-linux-2.13-pre6

How reproducible:
always

Steps to Reproduce:
1. cal
2. cal --help
3. TERM= cal
  
Actual results:
1. current date highlighted
2. no option to control highlight
3. no highligh, but had to check source code first

Expected results:
Normally options to control program behavior are done from command-line.

Additional info:
Fortunately cal has plenty of options available. Perhaps it would be better to
default to non-highlight anbd allow user to opt for highlight through option
"-v" (with an alias).  But also, it might be useful to generalize to
highlighting specific day(s) and not just today, with "-v YYYY/MM/DD" or "-v today".

I have already patched for above change, but will not attach it because normal
RedHat behavior is to reject everything I submit.
Comment 1 Karel Zak 2006-10-05 10:05:34 EDT
This is good idea, but we're very conservative with new command line options to
basic system utils. We prefer add these changes to upstream code rather than
create a distribution specific option.
Comment 2 Karel Zak 2007-04-06 06:28:49 EDT
Please, send the patch (to me or to upstream mailing list:
util-linux-ng(at)vger.kernel.org or add it to BZ as attachment). Thanks.
Comment 3 Karel Zak 2007-09-18 04:06:36 EDT
Well, this feature will be added to version util-linux-ng-2.14.

Note You need to log in before you can comment on or make changes to this bug.