Bug 208526 - Problem with hdparm or udma
Problem with hdparm or udma
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hdparm (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-29 02:26 EDT by Thomas Boerkel
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-10 07:00:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Boerkel 2006-09-29 02:26:15 EDT
Description of problem:
The hard disk on this PC was running with udma with Fedora Core 3. FC5's hdparm
now says otherwise. Either it is NOT using udma or hdparm tells the wrong story.

Version-Release number of selected component (if applicable):
hdparm-6.3-2.2

How reproducible:
hdparm -iv /dev/hdb

Steps to Reproduce:
1.
2.
3.
  
Actual results:
hdparm says "no udma", because there is no "*" behind a udma mode. However,
using_dma is 1. I do not remember, if udma mode was udma2 or udma4 on FC3.

# hdparm -iv /dev/hdb
/dev/hdb:
 multcount    = 16 (on)
 IO_support   =  0 (default 16-bit)
 unmaskirq    =  0 (off)
 using_dma    =  1 (on)
 keepsettings =  0 (off)
 readonly     =  0 (off)
 readahead    = 256 (on)
 geometry     = 16383/255/63, sectors = 156368016, start = 0

 Model=SAMSUNG SV0802N, FwRev=TP100-24, SerialNo=S019J10XB28950
 Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs }
 RawCHS=16383/16/63, TrkSize=34902, SectSize=554, ECCbytes=4
 BuffType=DualPortCache, BuffSize=2048kB, MaxMultSect=16, MultSect=16
 CurCHS=16383/16/63, CurSects=16514064, LBA=yes, LBAsects=156368016
 IORDY=on/off, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
 PIO modes:  pio0 pio1 pio2 pio3 pio4
 DMA modes:  mdma0 mdma1 mdma2
 UDMA modes: udma0 udma1 udma2
 AdvancedPM=no WriteCache=enabled
 Drive conforms to: (null):  ATA/ATAPI-1 ATA/ATAPI-2 ATA/ATAPI-3 ATA/ATAPI-4
ATA/ATAPI-5 ATA/ATAPI-6 ATA/ATAPI-7

dmesg suggests UDMA(100) is available:

# dmesg | grep hdb
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:pio, hdb:DMA
hdb: SAMSUNG SV0802N, ATA DISK drive
hdb: max request size: 512KiB
hdb: 156368016 sectors (80060 MB) w/2048KiB Cache, CHS=16383/255/63, UDMA(100)
hdb: cache flushes supported
 hdb: hdb1 hdb2 hdb3 hdb4
EXT3 FS on hdb2, internal journal
EXT3 FS on hdb1, internal journal
Adding 1052248k swap on /dev/hdb3.  Priority:-1 extents:1 across:1052248k

The only other drive (hdc) in this PC is a DVD drive and this one's using udma4,
according to hdparm.

Expected results:
udma should be used.

Additional info:
Comment 1 Karsten Hopp 2007-07-10 07:00:46 EDT
Please try again with the latest hdparm-7.6 from rawhide and reopen if this
problem still exists

Note You need to log in before you can comment on or make changes to this bug.