Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 2085517

Summary: [RHOS 17] Stopped VM failed to resize due to Unable to create allocation for 'VCPU' on resource provider
Product: Red Hat OpenStack Reporter: James Parker <jparker>
Component: openstack-novaAssignee: OSP DFG:Compute <osp-dfg-compute>
Status: CLOSED INSUFFICIENT_DATA QA Contact: OSP DFG:Compute <osp-dfg-compute>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17.0 (Wallaby)CC: dasmith, eglynn, jhakimra, kchamart, sbauza, sgordon, smooney, vromanso
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 2085576 (view as bug list) Environment:
Last Closed: 2022-05-26 10:46:13 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2085583, 2085587    
Bug Blocks:    
Attachments:
Description Flags
Failure logs based around resize request none

Description James Parker 2022-05-13 15:00:21 UTC
Created attachment 1879427 [details]
Failure logs based around resize request

Description of problem: Unable to resize a stopped VM with latest phase3 puddle RHOS-17.0-RHEL-9-20220511.n.1, this is the first puddle this has happened for 17 and was previously passing. Also this test is failing across a couple of jobs [1,2].  Example build failure and logs here [3,4].  Failure logs attached as well.

Version-Release number of selected component (if applicable):
RHOS-17.0-RHEL-9-20220511.n.1

How reproducible:
First time seeing this for 17 with latest puddle, happened across several jobs.

Steps to Reproduce:
1. Deploy environment with RHOS-17.0-RHEL-9-20220511.n.1 and execute tempest test tempest.api.compute.servers.test_server_actions/ServerActionsTestJSON/test_resize_server_confirm_from_stopped_id
2.
3.

Actual results:
VM remains in SHUTOFF state, fails to migrate, and never resizes

Expected results:
VM resizes

Additional info:
[1] https://rhos-ci-jenkins.lab.eng.tlv2.redhat.com//job/DFG-compute-nova-17.0_director-rhel-virthost-1cont_2comp_3ceph-ipv4-geneve-live-migration-shared-storage-config-drive-vfat-phase3/9//testReport/tempest.api.compute.servers.test_server_actions/ServerActionsTestJSON/test_resize_server_confirm_from_stopped_id_138b131d_66df_48c9_a171_64f45eb92962_/
[2] https://rhos-ci-jenkins.lab.eng.tlv2.redhat.com//job/DFG-compute-nova-17.0_director-rhel-virthost-1cont_2comp_3ceph-ipv4-geneve-smt-whitebox-numa-tests-ceph-phase3/8//testReport/tempest.api.compute.servers.test_server_actions/ServerActionsTestJSON/test_resize_server_confirm_from_stopped_id_138b131d_66df_48c9_a171_64f45eb92962_/
[3] https://rhos-ci-jenkins.lab.eng.tlv2.redhat.com/job/DFG-compute-nova-17.0_director-rhel-virthost-1cont_2comp_3ceph-ipv4-geneve-smt-whitebox-numa-tests-ceph-phase3/8/
[4] http://rhos-ci-logs.lab.eng.tlv2.redhat.com/logs/rcj/DFG-compute-nova-17.0_director-rhel-virthost-1cont_2comp_3ceph-ipv4-geneve-smt-whitebox-numa-tests-ceph-phase3/8/

Comment 4 smooney 2022-05-13 16:21:09 UTC
when looking at theh logs we noticed that the compute agent is being blocked by ovs. we ware cloning this into separate bugs to tack backporting the os-vif and ovsdbapp patches that work around the os issue.
we can keep this to investigate the ci issue incase its unrelated to the ovs issue.

Comment 5 smooney 2022-05-25 14:09:47 UTC
looking at the latest build for the affected jobs while they are still failing on other test the one in question appear to now be working
as such i think we should close this specific bz as i don't think there is anything actionable.

the other bz for the ovsdbapp backport and os-vif backport are till valid enhancements so can remain open seperately

Comment 8 Red Hat Bugzilla 2023-09-18 04:37:09 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 120 days