Bug 208555 - Take copy of CSS and PNG files for release-notes for anaconda display
Take copy of CSS and PNG files for release-notes for anaconda display
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
mipstx49 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-29 08:21 EDT by Paul W. Frields
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-15 17:15:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul W. Frields 2006-09-29 08:21:52 EDT
Description of problem:

The expected fedora.css and admonition {tip,warning,note,caution,important}.png
files do not appear in Anaconda's /tmp directory where they are expected by the
release-notes.  When displaying the release-notes in the Anaconda installer, the
style is missing, which is no big deal -- but it's probably a more important bug
that admonitions are not "sticking out" because their notational icons aren't
included in the loader's environment.

When you get a copy of the release notes HTML, can you also get a copy of the
CSS and the stylesheet-images/ directory?  They are very small and should not
cause substantial bloat.


Version-Release number of selected component (if applicable):
anaconda-11.1.0.101-1

How reproducible:
Every time

Steps to Reproduce:
1. Run installer (GUI)
2. Load release notes at appropriate point.
3. Examine admonitions and note missing icons.  Messages on tty1 reflect missing
files reported by release notes rendering.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2006-09-29 10:50:32 EDT
The problem is that we pull the release notes at runtime from the install source
-- and there's no guaranteed way to be able to pull a whole directory via
HTTP/FTP (directory listings don't have to be allowed by servers) which screws us.

We *cannot* be depending on files external to the release notes file itself for
the release notes.
Comment 2 David Cantrell 2007-03-15 17:15:56 EDT
Closing as CANTFIX per comment #1.

Note You need to log in before you can comment on or make changes to this bug.