Bug 208610 - black screen when hitting rhgb
Summary: black screen when hitting rhgb
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
medium
high
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact:
URL: https://www.redhat.com/archives/fedor...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-29 17:19 UTC by David Nielsen
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 15:25:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (69.98 KB, text/plain)
2006-09-29 17:30 UTC, David Nielsen
no flags Details

Description David Nielsen 2006-09-29 17:19:03 UTC
Description of problem:
After the following fix:
> - xorg-x11-server-1.1.1-vt-activate-is-a-terrible-api.patch: Since the
>   VT_ACTIVATE/VT_WAITACTIVE pair are never guaranteed to successfully
>   complete, set a 5 second timeout on the WAITACTIVE, and retry the pair
>   until we win.  (#207746)

went in I had expected a return to working rhgb but instead I'm greeted by a
black screen. doing ctrl+alt+backspace restores the boot process.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.1.1-43.fc6

How reproducible:
100%

Steps to Reproduce:
1. boot system
  
Actual results:
black screen

Expected results:
rhgb

Additional info:
AMD64 X2

Comment 1 David Nielsen 2006-09-29 17:30:36 UTC
Created attachment 137408 [details]
Xorg.0.log

And it helps if I actually attach the log file.. doh

Comment 2 Adam Jackson 2006-09-29 17:51:13 UTC
rpm -q xorg-x11-drv-ati

I suspect the DAC hack added in -2 is turning off your output when it shouldn't.

Comment 3 David Nielsen 2006-09-29 18:07:17 UTC
xorg-x11-drv-ati-6.6.2-11

I don't get that.. -2 should be the most recent one.. -11 ?? 

Comment 4 David Nielsen 2006-09-29 18:13:53 UTC
okay I removed the driver and reinstalled the -2 one released today, same problem.

Comment 5 Adam Jackson 2006-09-29 18:25:31 UTC
Try this test RPM:

http://people.freedesktop.org/~ajax/fedora/xorg-x11-drv-ati-6.6.2-2.fc6.jx.x86_64.rpm

(For the curious: changes the if (!bConnected) check in
radeon-6.6.2-dac-fix.patch to if (0), which should prevent us from turning off
the DAC, which would be one obvious source of black screens.)

Comment 6 David Nielsen 2006-09-30 18:04:24 UTC
well I tried booting after todays update since I saw an update from Dan Walsh to
selinux-policy that simply read "Fix rhgb". Regardless, this time rhgb pops. Can
anyone confirm the now non-brokenness of the behaviour?

Comment 7 Adam Jackson 2006-10-02 15:25:17 UTC
dwmw2 reports that the workaround in comment #5 works for him.  Adding to
6.6.2-4, and closing.


Note You need to log in before you can comment on or make changes to this bug.