RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 2086100 - RHEL 8.6 anaconda installer crashes
Summary: RHEL 8.6 anaconda installer crashes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: kdump-anaconda-addon
Version: 8.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Coiby
QA Contact: xiaoying yan
Sagar Dubewar
URL:
Whiteboard:
: 2085321 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-05-13 20:25 UTC by Suraj Raskar
Modified: 2022-11-08 10:34 UTC (History)
10 users (show)

Fixed In Version: kdump-anaconda-addon-003-8.20220519gitffd365e.el8
Doc Type: Bug Fix
Doc Text:
.Anaconda no longer fails after entering a passphrase for encrypted devices Previously, if `kdump` was disabled when preparing an installation, and the user selected encrypted disk partitioning, the Anaconda installer failed with a traceback after entering a passphrase for the encrypted device. This update fixes the problem, and users no longer need to enable `kdump` to create encrypted disk partitioning.
Clone Of:
Environment:
Last Closed: 2022-11-08 09:40:37 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)
Traceback which occuring after entering passphrase (2.04 MB, text/plain)
2022-05-13 20:25 UTC, Suraj Raskar
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHELPLAN-122030 0 None None None 2022-05-13 20:39:21 UTC
Red Hat Product Errata RHBA-2022:7566 0 None None None 2022-11-08 09:40:40 UTC

Description Suraj Raskar 2022-05-13 20:25:51 UTC
Created attachment 1879547 [details]
Traceback which occuring after entering passphrase

Description of problem:

RHEL 8.6 anaconda installer crashes

TypeError: Argument 1 does not allow None as a value



Version-Release number of selected component (if applicable):

- Anaconda 33.16.6.7


How reproducible:

- Always.


Steps to Reproduce:

1. Launch the RHEL 8.6 installer
2. Disable kdump
3. Go to partitioning and (a) choose custom, (b) click the "encryption" checkbox, (c) auto-create an LVM partitioning scheme, then crash when you go to accept changes after entering password.


Workaround:

Disable the Kdump in last.

Comment 1 Jan Stodola 2022-05-16 07:59:14 UTC
This is a regression comparing to RHEL-8.5. I'm not able to reproduce the same problem on RHEL-9.0
It's also possible to reproduce it when using automatic partitioning with encryption, it's not necessary to enter the custom partitioning spoke.

A workaround is to define the partitioning first and then disable kdump.

Comment 5 Jiri Konecny 2022-05-16 11:08:30 UTC
Based on the comment 3 switching to kdump addon. Thanks Vendy for looking on that.

Comment 12 Coiby 2022-05-19 10:35:23 UTC
*** Bug 2085321 has been marked as a duplicate of this bug. ***

Comment 22 errata-xmlrpc 2022-11-08 09:40:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (kdump-anaconda-addon bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:7566


Note You need to log in before you can comment on or make changes to this bug.