Bug 208618 - anaconda cannot install via serial console
anaconda cannot install via serial console
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
: Regression
Depends On:
Blocks: fedora-ia64 208801
  Show dependency treegraph
 
Reported: 2006-09-29 14:27 EDT by Doug Chapman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 11:09:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2006-09-29 14:27:04 EDT
Description of problem:
Booting the installer with a serial console anaconda is still starting the X
server and trying to run the X11 gui version.

I have tried this with no boot options and I have also tried passing "serial"
and "console=ttyS1" and it still runs X11.

This is on a system that has a video card however the system is configured to
use the serial console.  I have not yet tried this version of rawhide on a
system that has no video hardware.


Version-Release number of selected component (if applicable):
anaconda-11.1.0.102-1

How reproducible:
100%

Steps to Reproduce:
1. boot on an HP Integrity server that has video hardware but is configured for
serial console (nearly all HP ia64 servers in rhts)
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2006-09-29 14:29:11 EDT
More info... appears this is only happening for kickstart installs.
Comment 2 Doug Chapman 2006-10-01 16:00:58 EDT
I just tried this on x86_64 and I see the same issue so it is not ia64 specific.
 Note that this breaks kickstart installs that require some user interaction.

Comment 3 Jeremy Katz 2006-10-02 11:09:30 EDT
Chris fixed this on Friday, we just didn't build a package as we were trying not
to rock the boat with the FC6pre candidate that was being tested.

Note You need to log in before you can comment on or make changes to this bug.