Bug 208624 - High speed USB HID devices not working
High speed USB HID devices not working
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Feeney
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-29 14:52 EDT by Stuart Hayes
Modified: 2007-11-16 20:14 EST (History)
6 users (show)

See Also:
Fixed In Version: RHBA-2007-0304
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-07 23:44:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix issue (624 bytes, patch)
2006-09-29 14:52 EDT, Stuart Hayes
no flags Details | Diff

  None (edit)
Description Stuart Hayes 2006-09-29 14:52:56 EDT
Description of problem:
High speed (USB 2.0) HID devices aren't working.  Specifically this was seen 
with a new USB 2.0 Avocent KVM dongle.

Version-Release number of selected component (if applicable):
2.6.9-42.EL

How reproducible:
Every time.

Steps to Reproduce:
1. Connect Avocent USB 2.0 KVM dongle.
2. Boot system.
3. Note that keyboard & mouse don't work.
  
Actual results:
Keyboard & mouse don't work (unless you unload the ehci-hcd driver).

Expected results:
Keyboard and mouse should work.

Additional info:
Unloading the ehci-hcd driver will allow you to use the keyboard.
The problem is that the usbhid driver (in hid-core.c) is modifying the 
interrupt URB interval for high speed devices, and then calling 
usb_fill_int_urb, which applies the same modification to the already-modified 
interval value, resulting in a ridiculous value, which the ehci driver won't 
even schedule.  The attached patch fixes the issue.
Comment 1 Stuart Hayes 2006-09-29 14:52:56 EDT
Created attachment 137420 [details]
patch to fix issue
Comment 2 Roffe Moshe 2006-10-11 09:15:06 EDT
i have the same issue. 

using IBM HS20 bladecenter, 8843 model and avocent kvm
i am getting an error on all consoles like this:

drivers/usb/input/hid-core.c: input irq status -84 received

it occurs all the time and keeps accumulating on message.log

why is that, and how to stop this? 

btw: i am using rhel 4 update 2.

moshe.
Comment 3 RHEL Product and Program Management 2006-11-29 15:07:32 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Pete Zaitcev 2006-11-29 18:09:52 EST
This bug is duplicate of bug 181669, but can't be closed as duplicate because
of difference in permissions. I am marking this bug as modified. The fix was
commited to 2.6.9-42.7.EL.
Comment 6 Jay Turner 2007-01-02 08:45:11 EST
QE ack for RHEL4.5.
Comment 9 Issue Tracker 2007-04-19 17:30:46 EDT
A fix for this issue has been included in RHEL4.5. Please test the Release
Candidate of RHEL4.5, which was released today to Partners, and let us know
if the problem is resolved. The Release Candidate can be downloaded from
here:

ftp://partners.redhat.com/af38ac4316ba20df2dec5f990913396d

Internal Status set to 'Waiting on Customer'
Status set to: Waiting on Client
Resolution set to: 'RHEL 4.5'

This event sent from IssueTracker by gcase 
 issue 106478
Comment 10 Red Hat Bugzilla 2007-05-07 23:44:34 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0304.html

Note You need to log in before you can comment on or make changes to this bug.