Bug 20865 - Pine 4.30 crashes on certain folders
Pine 4.30 crashes on certain folders
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: pine (Show other bugs)
7.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-14 15:20 EST by Eivind
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-14 14:11:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eivind 2000-11-14 15:20:28 EST
The new pine 4.30 is completely broken, it crashes on opening certain
folders. It appears that the crashes are triggered by certain
folder-contents, because it will (repeatedly) crash on opening some
folders, and never on others. I estimate that it crashes on something like
3-5% of my folders, including remote folders like nntp-newsgroups.

I've had the same problem with a version I compiled myself out of the
official pine-sources, so it's unlikely that the problem is induced by
RedHat spesifically.

If required I can provide copies of my config-file, folders that crash
pine, or other info you migth need.
Comment 1 Eivind 2000-11-15 03:57:37 EST
I have done some more experimentation, and I'm only able to reproduce this with
sorting set to the new "tHreaded" sorting. (which sorts by message-references)

This feature is new in pine 4.30, so I've concluded that the likely bug is just
here. Thus this will affect only a relatively small number of advanced pine
users who use all the options, I've downgraded the bug to low severity.
Comment 2 Mike A. Harris 2000-11-19 21:41:54 EST
Please provide me a copy of your config.  Also, try to narrow down a folder
to the minimum number of messages that trigger the flaw, and include
the folder as well.
Comment 3 Eivind 2000-11-20 11:58:55 EST
I've sent the requested info to mharris since I didn't see any way of adding
files in this web-interface. If anyone else needs the files to reproduce the
bug, feel free to contact me.
Comment 4 Eivind 2000-12-14 14:11:32 EST
This bug is fixed in pine 4.31 available from washington.edu
Comment 5 Mike A. Harris 2001-01-28 19:31:56 EST
Fixed in PINE 4.32 in Rawhide.

Note You need to log in before you can comment on or make changes to this bug.